Vacation reply using wrong default sender address (NS7, sogo 3.2.9 but maybe all)


(Andreas Schloegl) #1

As many of us having to less holidays it’s not surprising that this bug was not recognised so far :slight_smile:

Activating the vacation reply will use the ‘default’ email address, which is wrong in my case (it was changed inside imap settings and can be seen on the top left of sogo window).
This situation will be typically for a multi mail domain setup (all users are placed in the same domain, but at least not all can use this domain for public mails)

You can manually change this email in the vacation setup and it will work - so it is a harmless bug, but having 50 users going to holiday you can guess how many of them will use the wrong email…
If you are using the wrong, no mail will be sent out!

Would be great if the email address from imap setting could be used here:


(Stéphane de Labrusse) #2

I’m not sure that we can trade with this…the good (or bad :slight_smile: ) practice of the samba ad wants a specific domain name which is saved in ldap. Sogo takes its domain name from ldap.

two solutions come immediately (not tested)

set your good domain name in samba ad, therefore you will have nothing to do following the installation (no custom settings in imap, no specific email sender for vacation).

for each user creation, set the good domain name for email (in imap) or for vacation, it is easy for a little office, less for a company


(Stéphane de Labrusse) #3

work out of the box, maybe we can add a note on the sogo wiki page to set the correct domain name for the email domain you want in the sambaAD domain name.

I recall that for SME Server I do the same, the first domain name is not a dummy one, it is the cons of this kind of distro (sme,NS) which can not have (really) several domains for email.

BUT for SME Server you can change as often you want the primary domain…it is not the case for NS ----> do a NFR to change in the UI the domain name of the account provider @dev_team


(Andreas Schloegl) #4

Hello @stephdl. Your solution set your good domain name in samba ad sounds easy to use, but I’m not sure where to do that. Is this a global setting for all or just a setting per user? Can you explain it in details pls where to set this?


(Stéphane de Labrusse) #5

When you install nethserver-dc(sambaAD) you give the domain name for all users. This domain name is retrieved by sogo from ldap as the default domain name.

Unfortunately once set, actually it cannot be changed.


(Andreas Schloegl) #6

OK, I’m with you. This is no solution in my case. As we can not change Sogo the way it works, I assume there will be no automatic solution - users have to set manually. Maybe we can inform Sogo developers to have a look on that?


(Davide Principi) #7

Does our SOGo config rely on AD userPrincipalName attribute? That should be the the corporate default user’s email address, as stated by Microsoft documentation.

Since the last Accounts provider update, userPrincipalName value ends with NethServer domain name suffix. It should be a valid public DNS domain name, like nethserver.org. See this actions:

If @asl configured his mail server before the update it’s likely the domain is private thus does not work well with email.

I’d like to develop a FQDN domain name rename procedure.


(Stéphane de Labrusse) #8

As you can see it seems to use userPrincipalName, but we might have also a side effect if SOGO save all users properties in its mysql database. Maybe we should do a fresh install and test it.

yes, it will be a good thing…once done, it can be imagined to do an event…and after an UI :slight_smile:


(Andreas Schloegl) #9

just to add that my server is running on enterprise edition, so I did not do any updates manually.
I also do have one on community edition - same problem.