Using external Mail Adress in SOGo :-( cant use the after adding

NethServer Version: 7.7
Module: SOGo Mail

Hello Guy

I hope sombody try that to :slight_smile: ! First thx to m.traeumner for finding the solution to Add a external extra Email to SOGo. I am adding a extra external email adress to SOGo. Using the User SOGo login than config -> Email ->IMAP -> Add Email.

Can be the Corona Times and the low ba(n)dswitch. Be carefull take a bottel of wine… Next day the Emails will be there…

now the question one.

The maildirectorys are confused and dobblet .

Any idea to reconstuct it ? or config it :slight_smile:

Next Question. It is possibel to use the external SMTP Server to?

THX for the support… Axel :slight_smile:

PS If ist ready i am trying a smal HOW to… writing …

I don’t know if you can use an external SMTP server, but you can create an alias at your server manager and use it as sender address at sogo.

What do you mean?

Hello Michael

all standart maildirictory are doubled. There are Entwürfe and Drafts… The same with sent, trash, spam. The external mailprovider uses the strukture like Posteingang

for some nomal user it is a lill bit confused …

Could you please post your sogo.conf?


I think you can set it with a template.

I found nothig about external mail only default


[root@sbs ~]# cat /etc/sogo/sogo.conf 
/* **************** DO NOT MODIFY THIS FILE **************** *
* Manual changes will be lost when this file is regenerated.
*  at
 * ********************************************************** */

 /* 10 Database configuration (mysql) */
   SOGoProfileURL = "mysql://sogo:dXNqyDKk_s53VJhI@localhost  /sogo/sogo_user_profile";
   OCSFolderInfoURL = "mysql://sogo:dXNqyDKk_s53VJhI@localhost    /sogo/sogo_folder_info";
    OCSSessionsFolderURL = "mysql://sogo:dXNqyDKk_s53VJhI@localhost/sogo/sogo_sessions_folder"; 
    OCSEMailAlarmsFolderURL = "mysql://sogo:dXNqyDKk_s53VJhI@localhost/sogo/sogo_alarms_folder";

  /* 20 Mail */

    SOGoDraftsFolderName = "Drafts";
    SOGoSentFolderName = "Sent";
    SOGoTrashFolderName = "Trash";
    SOGoJunkFolderName = "Junk";
    SOGoIMAPServer = "localhost";
    SOGoSieveServer = "sieve://localhost:4190";
    SOGoSMTPServer = "";
    SOGoMailDomain = "";
    SOGoSMTPAuthenticationType = "PLAIN";
    SOGoMailingMechanism = "smtp";
    NGImap4ConnectionStringSeparator = "/";

  /* 30 Notifications */
    SOGoFoldersSendEMailNotifications = NO;
    SOGoACLsSendEMailNotifications = NO;
    SOGoAppointmentSendEMailNotifications = YES;
    SOGoEnableEMailAlarms = YES;

  /* 40 Authentication */
  //SOGoPasswordChangeEnabled = YES;

  /* 45 AD authentication */
    SOGoUserSources =(
        id = AD_Users;
        type = ldap;
        CNFieldName = cn;
        IDFieldName = sAMAccountName;
        UIDFieldName = sAMAccountName;
        IMAPLoginFieldName = userPrincipalName;
        canAuthenticate = YES;
        bindDN = "ldapservice@AD.sub.domain.DE";
        bindPassword = "LDAP_PW";
        baseDN = "dc=ad,dc=sub,dc=domain,dc=de";
        bindFields = (
        hostname = ldaps://;
        filter = "(objectClass='user') AND (sAMAccountType=805306368)";
        MailFieldNames = ("userPrincipalName");
        scope = SUB;
        displayName = " users";
        isAddressBook = YES;
        id = AD_Groups;
        type = ldap;
        CNFieldName = name;
        IDFieldName = sAMAccountName;
        UIDFieldName = sAMAccountName;
        canAuthenticate = YES;
        bindDN = "ldapservice@AD.sub.domain.DE";
        bindPassword = "LDAP-PW";
        baseDN = "dc=ad,dc=sub,dc=domain,dc=de";
        hostname = ldaps://;
        filter = "(objectClass='group') AND (sAMAccountType=268435456)";
        MailFieldNames = ("mail");
        scope = SUB;
        displayName = " groups";
        isAddressBook = YES;

  /* 50 Web Interface */
    SOGoVacationEnabled = YES;
    SOGoForwardEnabled = YES;
    SOGoSieveScriptsEnabled = YES;
    SOGoMailAuxiliaryUserAccountsEnabled = YES;
    SOGoMailCustomFromEnabled = YES;
  //SOGoFirstDayOfWeek = 1;
  //SOGoMailReplyPlacement = "above";
  //SOGoMailSignaturePlacement = "above";

  /* 60 General */
    SOGoTimeZone = Europe/Berlin;
    SOGoSuperUsernames = (admin); // This is an array - keep the parens!
    SOGoMemcachedHost = "";
    SxVMemLimit = 512;
    SOGoEnablePublicAccess = YES;

  /* From Nethesis GNUStep configuration
     Undocumented in sogo instalation manual */
     SOGoAppointmentSendEMailReceipts = YES;

  /* 70 Active Sync options and tuning */
    SOGoMaximumPingInterval = 3540;
    SOGoMaximumSyncInterval = 3540;
    SOGoInternalSyncInterval = 30;
    SOGoMaximumSyncResponseSize = 2048;
    SOGoMaximumSyncWindowSize = 100;

    WOWatchDogRequestTimeout = 60;
    WOWorkersCount = 10;

  /* 75 enable cal- and carddav */
    SOGoAddressBookDAVAccessEnabled = YES;
    SOGoCalendarDAVAccessEnabled = YES;

  /* 80 Debug */
  //SOGoDebugRequests = YES;
  //SoDebugBaseURL = YES;
  //ImapDebugEnabled = YES;
  //LDAPDebugEnabled = YES;
  //PGDebugEnabled = YES;
  //MySQL4DebugEnabled = YES;
  //SOGoUIxDebugEnabled = YES;
  //WODontZipResponse = YES;
  //SOGoEASDebugEnabled = YES;
  //WOLogFile = "/var/log/sogo/sogo.log";

I hope it is helpfull
THX Axel

You are right, there is no setting for the second imap server. I think you can only change the folders for the first one, or it’s for both at the same time.
Perhaps @stephdl knows a little bit more about it.

I think yes it is normal, you have added a new different imap account, each account gets its folders, I do not know about something unified

for the smtp, I think the default/mandatory is to use the NethServer one, but I think in each account you can set the sender name you need/want

Hello Stephane

thx for answering… But it not nice for the WAF. In my Email Client i can reconfig it :slight_smile: and i Like to reconfig it to for sogo.

If i startet and the mapping ist differend that it is must to start …

And it can bedifferend form Mailbos to mailbox :frowning:

Yes i Hope i can send a default/mandatory for each user or a wildcard that killd the sub.domain … -> When the mail is not internal …


Hi Stephane,
Axel has for one mail account a folder drafts at the inbox folder and the same folder (in German it’s “Entwürfe”) out of inbox. The cause is that the mail provider has an other folder structure then sogo. Because of this the question is, to change the standard folders like sent and drafts to other ones, but we can’t find a solution to do this for the external account only.

1 Like

I do not know if we have the hand on an external repository, I have two accounts for the same user but it is stephane@* and stephdl@*, all are on the same server :-?

need to check not yet time now

1 Like

If you can put your hand into the mail server it is easy … or if it the same Server. Than we can config the Imap server.

But this one is a provider Imap-server i will have a look whts happend …

mutsh better will be a “Redirect” fo correct mail dir

:slight_smile: so i had to do deep RTFM on Sogo

but good to know that there is /etc/sogo/sogo.conf

1 Like

Please use templates to change settings at the config. If you have questions, we are here.

1 Like

Witch part of sogo.conf will be use to confing external Emailsettings ?

IIRC we just enable or disable the permission to use external account, after it is SOGo itself which make the things work

SOGoMailAuxiliaryUserAccountsEnabled = YES;