User with no ssh access can't login into cockpit

NethServer Version: 7.7.1908 (final)
Module: cockpit login

I don’t know if it’s a bug or if it’s ment to be so, but if a user hasn’t ssh access enabled, it’s not possible to login into cockpit to change his password. I think it has to with terminal, but a normal user do not has to have terminal access only to change his password.
IMO a user shold be able to do, also he has no ssh access.
Can you please explain this behaviour @davidep or @giacomo ?

TIA Ralf

1 Like

From 7.7 release notes:

Only users with enabled shell can access the new Server Manager. From the old Server Manager, go to the Users and groups page and enable the Remote shell (SSH) option for the selected user. From the new Server Manager, go to the Users and groups page and enable the Shell option for the selected user. http://docs.nethserver.org/en/v7/release_notes.html#major-changes-on-2019-10-07

We’ll add a user password changing form as a separate page soon.

1 Like

Orthogonal answer, but there’s another way to accomplish that:
https://wiki.nethserver.org/doku.php?id=userguide:self-service-password

2 Likes

Sorry missed that. Thanks for clarifiing.

Looks really nice. Does it work with all account provider (LDAP / AD local / remote) ?
Thanks for this info.

I’m not aware that it’s been tried with remote account providers. I use it myself for local LDAP, and others have successfully tested it with local AD. I would expect it should work with remote LDAP, though probably not using the email tokens. Remote AD, no idea there.

Will this have separate access controls, such that it could be open to Red without the server manager as a whole being open to Red? I’d be happy for my self-service-password module to be redundant.

Yes I’m referring to our past discussion

I can’t say by now if it will remain as alternative, or enter the “core” :wink:

Thanks for your reply.
As I work with local AD I’m happy! :slight_smile: