USB/LAN adapter not detected by installation

I agree with @Stefano_Zamboni: elrepo has a solid reputation. If you find a driver there it’d work well.

2 Likes

Strangely, I had a similar problem early this week when diagnosing a problem between a FreeBSD installation and a USB / NIC (Realtek 2832 based chipset), I resolved the problem by replacing the USB device with a RAlink 2800 based USB / NIC (I would have used a PCI based wireless NIC but the computer did not have any free PCI slots).

I would suggest that if forced to use any type of USB device, confirm that the operating system supports it before trying to install said device (I have also had previous problems with installing certain USB / DAB / DVB devices on a Debian based installation).

Which NethServer release?
The drivers (kmod-ax88179_178a) are in elrepo but the ones for CentOS 7 complain about the kernel version.

You can report the problem to elrepo bug tracker to see if they can fix it.
Neither a linux expert, but if you need assistance or want me to report it on your behalf I’m open to that.

1 Like

Good evening everyone,

thank you for all your advices. So what I did:
Created new interface - bridged, because couldn’t change green to red. It was saying, cannot remove (or change, not sure) the red interface.
I’ve installed all updates + some packages like DHCP and DNS, basic firewall. Unfortunately now in Software centre it is not showing any package and says I should clear YUM cache because the install /update may have failed due to metadata caching issues. Clicked the button, couple times, but not working, it is still there.
As well, I went through all the links you provided and came to the conclusion, there are only 2 options (correct me if I am wrong):

  1. download the drivers from elrepo - but in case these are not correct it might not work (I have System versionNethServer release 6.8 (Final), Kernel release2.6.32-642.4.2.el6.x86_64)
    If I get it right, it might even happen, that sometimes in the future I upgrade NS, but the drivers won’t be updated and then I am without network.
  2. buy USB NIC that has support directly by CentOS/Redhat - any advices which it might be?

Don’t get me wrong, but I just don’t want to spend 300€ for another miniPC having 2 internal NICs just for ‘home use’. Therefore I would need to make this work somehow, or stay with Zentyal (don’t really like this option).

Thank you one more time for all your help and quick responses.

Marian

Hi Marian,

Unfortunately all that I read regard to USB to LAN adapter drivers for CentOS is related to the Kernel versions, and must be compiled from sources.

I didn’t found, on a quick search on Google, an USB to LAN adapter to work on CentOS 6 or 7. That didn’t mean that aren’t.
Curiously, there are a lot of USB to Wireless adapters that works.

As @Stefano_Zamboni said, if you compiled the drivers for the current kernel version, in case of an upgrade, couldn’t work anymore.

Finally, IMO, the best/only solution is to change the hardware.

BR,
Gabriel

2 Likes

To resume the available options to have it running:

  1. New USB to LAN adapter supported by the kernel: usually you need to identify the chipset used by the device and find out if it’s supported by the kernel.
    Easier with popular chipsets (realtek, ralink…), but the device manufacturer may not provide that info and you have to find it out by others means, as @GG_jr did (looking at the drivers page).

  2. Install 3rd-party pre-compiled drivers (kernel module) for your device: luckily they’re available at ELRepo and the ones for Centos 6 can be installed without complain (I tested them on the same kernel you have and with the previous one). ELRepo compiles them in a way to make them work, in most cases, even after kernel updates (but exceptions may arise).

  3. Manually compile the drivers: more difficult than the other methods. Problems on kernel updates. Needs compiling tools not always desirable to have on an Enterprise distribution.

  4. Install a main-line kernel: that is a kernel with more recent features (more supported devices). ELRepo has a repository for that. More experienced members will be able to give the pros and cons. I think your device is supported (at least) from kernel >=3.18.

The first option is the safer.

5 Likes

This recap is great and reusable in every situation with fancy hardware :slight_smile::+1:

1 Like

Hello,

great, thank you for the recap. I was googling around a bit and I’ve found this one, seems it has RTL8153 chip.
I tried to check on the Red Hat Customer Portal, but I haven’t found it there.

Would anyone be able to tell me if NS would work with that chip please?

Thank you.

1 Like

I think it’s not supported without using external drivers. RTL8153 uses RTL8152 drivers, but cannot find them on CentOS 6:

grep -ir 'rtl815[23]' /lib/modules/$(uname -r)/kernel/drivers/net/usb/

/boot/config-$(uname -r)

But this one and the AX88179 you own are included on CentOS 7 (sorry, I’ve mistakenly tried the ELRepo driver without knowing the device was natively supported).

In the 2nd point of the previous message I forgot to say that IF the drivers stop working after a kernel update, I still believe the computer can be booted from the previous kernel, giving some time to look for a fix.

P.S. Other helpful resources: Linux Kernel Driver Database, Linux Hardware Guide

1 Like

Sorry, I am a bit confused now … so if I get it right … I have NS 6.8 that runs on CentOS 6. That means these drivers are not included, I suppose.
Therefore should I install them from ELRepo? (if yes, how please?)
Or should I install CentOS7 and on that one install NS 6.8? (no idea how to do that and what to choose in the CentOS installation)
Or should I install the NS 7 alpha2? Is it running on CentOS 7? I suppose this is not a final version, so would I be able to run this (Linux noob) or does that require any special tweaking, tuning, …?

Thank you.

1 Like

Hi Marian,

IMO, it doesn’t matter how to install NS, or which version of NS (CentOS) do you intend to use.
The only problem are the drivers.
If you don’t have the proper drivers, you cannot use the USB to LAN adapter.

The best approach is to use a combination of hardware that match the OS base platform (in this case CentOS 6.xx for NS 6.xx, or CentOS 7.xx for NS 7.xx).

It’s a little bit more complicated than for Windows OS, because not all the hardware producers, or the chipset producers, build drivers also for Linux.

EDIT:

Also, the producers of the Linux distros have different approach regarding the proper environment where will be used their distro
Please review what @Stefano_Zamboni said in his posts.

Gabriel

1 Like

Hi Gabriel,
OK, got it. So in that case would it be better to install the NS7 alpha2 version that (seems) includes the drivers?Can I use that as a stable version (so basically rely that it will work properly without issues)?

Hi Marian,

NS Alpha 2 is “very” outdated. Cannot be used anymore.

The latest version is NS Beta 2 which is based on the same version of CentOS.
I’m not sure about the Kernel version.

If the drivers of your USB to LAN Adapter was available on Alpha 2 version, I’m pretty sure that are available also in the Beta 2 version.
I don’t know if the drivers are related to the Kernel version.

The NS Beta 2 version is the closest version to the final version.
You can try to install NS Beta 2 and see what is happened.

Gabriel

Hello,

so I tried the Beta 2 version, but seems I am not able to boot it directly from DVD. So I decided to try to download the drivers from elrepo.
I logged in as root (directly in the device where the NS is installed, not via SSH) and wrote:
sudo rpm --import https://www.elrepo.org/RPM-GPG-KEY-elrepo.org
and it says:
curl: (6) Couldn’t resolve host 'www.elrepo.org
error: import https://www.elrepo.org/RPM-GPG-KEY-elrepo.org: import read failed (2)

Any idea where the problem is please?

If you can ping www.elrepo.org try the rpm commands with http instead of https.
If logged as root you don’t need to use sudo.

You can use either:

rpm --import https://www.elrepo.org/RPM-GPG-KEY-elrepo.org
rpm -Uvh http://www.elrepo.org/elrepo-release-6-6.el6.elrepo.noarch.rpm
yum install kmod-ax88179_178a

or:

yum install http://www.elrepo.org/elrepo-release-6-6.el6.elrepo.noarch.rpm
yum install kmod-ax88179_178a

If we can help with the NS7 beta 2 DVD just give us some details on the boot problem. :wink:

1 Like

hmm … I tried to ping with www only, then with http as well as https and it says
ping: unknown host www.elrepo.org

when pinging first time, it says I have new mail in /var/spool/mail/root

btw. issue with the NS7 beta 2 was, that after downloading from SourceForge, I burned it to DVD and it is not recognised as booting CD/DVD. It is always asking to insert a bootable media.
It is not issue of the DVD drive, because when I try the same with NS 6.8 it works from the first restart.

Hi Marian,

I just begin the installation of the NS Beta 2 on a dedicated server from DVD-ISO (burned with Nero 10 Essentials, burning speed: safe mode, “Quick copy …” not checked), without issues.

( NethServer 7 beta2 ISO is coming up )

Can you ping any other domain?
If not, verify the DNS settings and that there is Internet access from NS.

1 Like

Hello gentlemen,

Marc’s reply solved the issue finally … I’ve installed the driver from Elrepo and … miracle … the adapter appeared and works. THANK YOU!

I have one more issue, not related to this at all, but I hope can “hi-jack” this thread for question … I have an external usb disk where I have data (hope they are still there). If I try to mount it to a folder it says mount: wrong fs type, bad option, bad superblock on /dev/sdb1, …
doing e2fsck it says superblock cannot be read or does not describe a valid …
so I did e2fsck -b 32768 and still the same error.

I am already desperate … I really would like to save the data (or at least as big part as possible) on that drive, however I have no idea what should I do.

Any suggestions please?

2 Likes

That’s a great news! Thank you for working with such perseverance

Please, keep the discussion tidy. I just opened a new topic for you

1 Like