USB/LAN adapter not detected by installation


I would like to ask you for help with the installation of Nethserver. I’ve got a mini-PC (Zotac) having one internal LAN adapter and second one through USB. The internal one is for the red zone and USB/LAN I am planning to have for the green zone.
The thing is, when I am installing the NS, the USB/LAN doesn’t show up. Same after installation … it cannot be selected, it is not there. Seems like it would be missing drivers. Any advices how to solve this please?
Preferably I would like to do that via installation or manually, because as I have only one interface, I can or be on the internet or connected via GUI, so seems I wouldn’t be able to start downloading from somewhere.

Thank you a lot!

Hello Marian,

Try to install NS with onboard NIC as GREEN.

After first setup, make all the updates, with USB NIC attached.
Maybe after updates the OS will see the USB NIC.

Anyway, you must check the USB NIC in RedHat/CentOS HCL, or, on the producer’s site, if there are drivers for RedHat/CentOS.

If everything will be OK, add the USB NIC as second GREEN and after that, change the onboard NIC from GREEN to RED.

If the USB NIC has no drivers for RedHat/CentOS, buy another USB NIC according with RedHat/CentOS HCL.


Hi Gabriel,

actually I did exactly that … I’ve installed it with the onboard NIC as green, but how can I download the updates? Because this device where NS is installed is my router, so I suppose I should have the NIC as red to be connected to internet, no? But when I set it to red, would I be able to access the management interface GUI?

I was trying to find the drivers (it is IB-AC501), but I am not successful. The thing is it works without any issue on Ubuntu.

I’ve checked the Redhat HCL and truly … it is confusing for me. I have no idea, how can I find any kind of USB NIC that is supported and would be working with CentOS. And as this is a mini-PC it has to be a USB NIC, because I do not have a free slot where I could fit an internal NIC.

Hi Marian,

I think you can reach the GUI from RED with: https://your_wan_ip:980

You can make the updates (from CLI) after login and if you are connected to the Internet:

yum update && yum upgrade

I hope I’m not wrong!

After that, reboot with the USB NIC connected and check if it’s seen.


With Ubuntu, I never had issues with my hardware components, from installation.
With CentOS, yes. After first updates, usually worked.

1 Like

Try an workaround:
I presume that you have a router which you want to replace with NS.
Install NS on Zotac with onboard NIC as GREEN, connected to the Internet through the LAN of your existing router.
Access the GUI from LAN, make the updates, and check the USB NIC.


Hi Gabriel,
Actually this was the router, having Zentyal inside. But good idea, I think I’ll find an older router somewhere and try that during this weekend.

Hi Marian,

I checked the producer site ( for Linux drivers and I didn’t find anything. Only for Windows.
Could you identify the Linux driver in the Ubuntu (Zentyal) installation?
Could help to find also for CentOS.

I found something here:

Can you check here:;71;112&PLine=71

to see if this is your product?


I’m pretty sure that this is your device: AX88179.
If you check the folders for Windows drivers you will find a folder named “ASIX Electronics Corporation”.


A “how to”, for an old Ubuntu, but you or who knows how to build a driver, can help you. Unfortunately, I don’t know.

1 Like

Hi Gabriel,
how can I identify the driver please? Sorry, but I am Linux noob, so I would need guide for dummies :-)Btw. I didn’t have to install anything additional… I’ve just installed Zentyal and the USB NIC was recognised automatically.

I’m a Linux noob too! :joy:
But Google can help us!

For this, I like Ubuntu! (Should I delete this? :wink: )

I think we should ask for help to build the driver for CentOS from the sources.

@dnutan, @giacomo, @davidep, @alefattorini

Will you help @MarianH , please? :pray:


NS comes from Centos, which is not a desktop distro but a server oriented one… so there’s (almost) no support for bleeding edge hw or exotic one… who would use an usb lan adapter in an enterprise environment?

that said, I suggest OP to search for another adapter, supported by centos and strongly advice eveyone that compiling drivers is not a smart idea… each time you update your kernel you’ll find your server with no connectivity (and it’s a nightmare to support)


You are right!
Nobody will use a mini-PC (Zotac) in an enterprise environment!

But NS is for everyone! For Enterprise and Home? Isn’t it?
So, I think we are here to help and encourage everybody to use NS! Or some of us, at least!

BTW, Ubuntu is also a server OS!

1 Like

you can obiously install centos/NS whenever you want, but you can’t expect that an enterprise oriented kernel (centos’ one) will support all the hw you’ll find out there

I know ubuntu can be used on a server too, but the approach is quite different from Centos (no OS war intended)

1 Like
  • you can obviously install centos whenever you want, but you can’t expect that an enterprise oriented kernel (centos’ one) will support all the hw you’ll find out there.

  • you can obviously install NS whenever you want, and you can expect that somebody from this Community will help you.

No war intended from me at all!

But please, let just keep this thread clean and let’s try to help Marian!

1 Like

The best advice is to find an USB/LAN adapter natively supported by the kernel
This will make his NS stable and his experience better, with no update/maintenance issues

1 Like

I know and agree with you!
I have tried to find on Google but it seems this is the only, and the driver must be compiled.

I think that an answer could be the elrepo kmod rpms:


I agree with @Stefano_Zamboni: elrepo has a solid reputation. If you find a driver there it’d work well.