UPS (NUT) doesn't configure the Riello UPS


NethServer Version: NethServer release 7.4.1708 (Final)
Module: UPS

Hi all, I tried to configure my UPS Riello with NS dedicated panel.

I have selected right driver (riello_ser) and device USB (auto) and then save. However,
I found this error in the panel: Task complete with error (#exitcode)

I have searched info a journalctl and I found this:

collectd[9889]: read-function of plugin `nut' failed. Will suspend it for 640.000 seconds.
collectd[9889]: nut plugin: nut_read_one: upscli_connect (localhost, 3493) failed: Connection failure: Connection refused

upsmon[9934]: UPS [UPS@]: connect failed: Connection failure: Connection refused

The settings in ups/ folder are:


pollinterval = 10
driver = riello_ser
port = /dev/ttyUSB0



Could anyone have tips on how to fix the problem?


Connection refused is usually something like a firewall being a pita or credentials not being right or not able to verify them. Seems only the first one would be applicable here, but I am not familiar with this configuration and cant advise beyond the obvious, so offer it just in case you should have missed that.

In Release note for NUT, I found info about what might cause the problem.

Release notes for NUT 2.7.3 - what's new since 2.7.2:

 - riello_usb/_ser: USB interface claim fix; improved error handling

I have verified the version of NUT used in NS and it is 2.7.2.

@giacomo, @davidep can I hope for a nethserver-nut update to fix the problem?

Hi @pasing,

I tried compiling but no success. There are some newer Fedora Packages:

Are you sure that nut has the problem? Are you able to try with newer nut or other app on another system?

Hi @mrmarkuz,
searching on the google I have found same NUT problem in other OS:

If I understand well, I think I have the same problem.

As you already found, it is probably a problem on nut packages.
The only thing we can do, is waiting a fix from upstream.

If I read right, has the fix doesn’t insert into a version of 2.7.3? The actual version of NUT is 2.7.4 or I’m wrong?

I don’t know, honestly I didn’t read external links. ::innocent:

But to sum up: if it’s a bug inside our configuration, we can fix it or try to find a workaround; if it’s a bug inside nut itself we can’t do anything about it rather than report the issue to nut developers.

I think you’re the only one who can find where is the issue, since we don’t have the same UPS hardware :slight_smile:

@giacomo reading the NUT release notes it appears that the correction was included in the 2.7.3 release. The question I asked is:

Since nethserver-nut uses version 2.7.2 of NUT, is it desirable to upgrade to the latest version?

We can’t since we follow upstream, if RHEL releases a new version of NUT, we will have it too. :wink:

Said that, you’re free to recompile the new NUT release for your own installation.

1 Like