Upgraded MeshCentral from 1.1.10 to 1.1.14 and get Service Unavailable

Just recently did an upgrade to MeshCentral while I was in MeshCentral. Upgrading from 1.1.10 to 1.1.14. After starting the upgrade MeshCentral will place a reconnect to server link in the center of the page. Usually in the past it will refresh and reconnect itself, but on this upgrade it sat on the click here to reconnect to server. So I clicked on the reconnect to server link in MeshCentral and what brought to a Service Unavailable page seen below -

Here’s is what we are working with -

NethServer release 7.9.2009 (final)

After I saw this I started to troubleshoot to see if I could get MeshCentral back up and running.
I also backed up my meshcentral-data and meshcentral-backup just in case.

I tried to stop meshcentral, start meshcentral, and restart meshcental that did not have any effect.

I also did systemctl status meshcentral, systemctl stop meshcentral, and systemctl start meshcentral

It showed a status, but was not running.

On the services page in nethserver the meshcentral.service would not start. I even tried to disable it and re-enable it. Did not work.

I decided to uninstall and then reinstall meshcentral with the following command -

yum -y --enablerepo=mrmarkuz remove nethserver-meshcentral
yum -y --enablerepo=mrmarkuz install nethserver-meshcentral

and no change. Still getting the Service Unavailable page.

So even though I was able to uninstall and reinstall yesterday from the mrmarkuz.dynu.net mirror, it looks like today that is not happening. I got the following -

I guess I may have to wait on the mirror to re-appear, or try manually installing it.

Any thoughts?


The server is reachable and I can download the meshcentral RPM from https://mrmarkuz.dynu.net/mirror/mrmarkuz/7/noarch/nethserver-meshcentral-0.0.1-1.ns7.noarch.rpm

You may try to download and install locally.

Maybe it helps to clean yum cache:

yum clean all


@Shadowfire As regards the meshcentral update to 1.1.14, I found following entry in /var/log/messages:

Oct 25 19:48:00 server2 node: MeshCentral requires Node v11 or above, current version is v10.24.0.

It seems at least nodejs 11 is needed and I used nodejs10 for meshcentral but now epel nodejs is version 16 so I need to upgrade the module.

As a workaround you could edit the meshcentral systemd service file to use the right nodejs version 16 from epel.

Stop meshcentral:

systemctl stop meshcentral

Edit the file /etc/systemd/system/meshcentral.service at line 7:

ExecStart=/usr/bin/node /opt/meshcentral/node_modules/meshcentral/meshcentral.js

Reload systemd config:

systemctl daemon-reload

Restart and reconfigure Meshcentral:

signal-event nethserver-meshcentral-update

After a minute meshcentral should be up again…


@mrmarkuz It sounds like you may have the answer. I will look and see if this works it out for me. Thanks for all the follow-ups on this. I appreciate it.

1 Like

I am am still having a issue with mrmarkuz.dynu.net Error 14 - Could not resolve host… So I found a past post about http://mirror-status.nethserver.org/ and so I went there and I saw the following.

I see the one in Germany with the name mrmarkuz.dynu.net, so I am guessing that is the one my server is trying to connect at. But I just wanted to make sure.


It should be possible to download from my server, I don’t do geoblocking. My domain is a dyndns domain and therefore could have a bad reputation so maybe it’s blocked on your side?

You could download directly as a workaround:


Or try the following:

yum install https://mrmarkuz.dynu.net/mirror/mrmarkuz/7/noarch/nethserver-meshcentral-0.0.1-1.ns7.noarch.rpm

As regards the yum error, maybe it helps to clean the metadata:

yum clean metadata --enablerepo=*

It seems the host can’t be resolved.
Does nslookup mrmarkuz.dynu.net. work?


@mrmarkuz I went into my firewall and change the DNS servers. Then I rebooted my computer, ssh in to my nethserver and did a yum clean all and yum update. I then did yum -y --enablerepo=mrmarkuz install nethserver-meshcentral and it installed and completed! Thank you! Thank you!~

Now I am going to try the meshcentral work around. I will update you.


1 Like

Once I was able to download the meshcentral package again from yum -y --enablerepo=mrmarkuz install nethserver-meshcentral
I was able to step though the solution post up above.

I was able to get to the login screen and login. Everything was as it should be. Thanks @mrmarkuz again for your help. You are a valued member like many on here. I really appreciate your help!


1 Like