Updating of BackupPC to v4.3.1

Man, thanks for being here trying to support our project. I hope @stephdl will use your advice accordingly
I’m so happy when I see things like that.

Hi Stéphane

I have, to the best of my ability, try to do it. :slight_smile:

But I don’t have enough insight into linux now.
So if you have 5min. maybe you can give me an idea of what to do.
Thank you in advance for your help so far.:smile:

Nethserver is not exactly made like other linux, you have a template layer (an engine to build configuration files) and it takes its vars from an e-smith database (several plain file databases where we store all vars we need). You could start to read some documentation https://wiki.nethserver.org/doku.php?id=howto:db_command_tutorial&s[]=smith

for what you need I did the rpm this morning, I only tested the installation and some basic changes in settings, now we need to valid if the backups are well done and if the restorations are good.


wget https://copr.fedorainfracloud.org/coprs/hobbes1069/BackupPC/repo/epel-7/hobbes1069-BackupPC-epel-7.repo -O /etc/yum.repos.d/backuppc.repo


yum install http://mirror.de-labrusse.fr/NethDev/nethserver-BackupPC4/nethserver-BackupPC4-1.1.5-1.ns7.sdl.noarch.rpm

1 Like

Forgot in my previous reply that there is a setup README as well.



1 Like

I migrated my own server, it seems that configuration of hosts are not lost but you have to recreate the host manually, only note somewhere the exact name, then go to edit host, then add the name of your previous host, verify in the setting of your host the previous values should be there.

This could break an automatic migration to v4

1 Like

pushed to my repo with a beta flag, you need to remove first the nethserver-BackupPC and BackupPC v3 (I added a conflict)

1 Like

I have tests as follows:
• A brand new install a Nethserver server
• Server update but all the latest updates
• Reboot server
• Server logged into my samba domain
• Reboot server
• Executed this commando: wget https://copr.fedorainfracloud.org/coprs/hobbes1069/BackupPC/repo/epel-7/hobbes1069-BackupPC-epel-7.repo -O /etc/yum.repos.d/backuppc.repo

• And then this command: yum install http://mirror.de-labrusse.fr/NethDev/nethserver-BackupPC4/nethserver-BackupPC4-1.1.5-1.ns7.sdl.noarch.rpm
Here I got these error messages:

• Now see that there are two new points under Applications

• Can also see under Services that backup does not run

• When I access the backuppc web interface I get this error message:

This may be because I don’t know where to edit host.?

please try this tutorial https://wiki.nethserver.org/doku.php?id=backuppc4

In the meanwhile I try to reproduce it with a new server

I cannot reproduce your error, it seems that the BackupPC rpm itself failed to create the user backuppc and like you see the service is down, this is not on my control (the rpm comes from copr), I rely on the user backuppc to create the ssh certificate.

warning: group backuppc does not exist - using root
warning: group backuppc does not exist - using root

I tested again on a fresh vm upgraded to 7.7, it works as expected

I just made a fresh server again,and here I get the same message during installation.

it is also the same error in the backuppc interface.

And the only thing i have done is run the two commanders standing on this homepage: https://wiki.nethserver.org/doku.php?id=backuppc4.

When but I am now trying with a fresh ISO file of nethserver, which does not need updating.
Maybe it’s in there?

what version of nethserver do you use ?

it seems that BackupPC cannot create the user backuppc

I have an image(proxmox) of a nethserver-7.6.1810-x86_64 that i update to the new version and then i install backuppc4.
But I just downloaded nethserver-7.7.1908-x86_64 and am making a fresh server which I update. and there after install backuppc4

1 Like

Now i have a new server.
What I’ve done is:
*install a new fresh server of nethserver-7.7.1908-x86_64
*update with the latest new stuff
*install your repository
*install backuppc 4 beta, got this error

*check that service backuppc was running, it did:-)
*open its website, and here I got a login dialog box. I should just say that the server it is not registered in my domain right now.
I have tried root + password and backuppc + root password.
But can not enter.Udklip20
*Ok, I thought then I join server into my domain.
And now it’s going to be interesting. after i join my domain, backup service stops running and it will not start again. If I unbind server out of domain again, backup service will run again.
But I can’t login into it since I don’t know what username and password I need

I found this in log:

I cannot understand why it could fail with samba AD… I really do not know

@all…could you try to debug, I am a bit stuck, please could you follow


tested with one nic and I can install the service.

What about logs (messages and backuppc) ?
What about output in log when you reinstall the the rpm BAckupPC (yum reinstall BackupPC)
Can you reproduce the same behaviour with BackupPC V3 ?

Since I cannot reproduce, I cannot fix it

Installation and access to BackupPC web-page went fine login in with different users of sambaDC (tested on sambaDC local account-provider). Service running, user backuppc created, signal-event seemed ok.
Didn’t test with a remote AD account provider, which seems to be the case of Michael’s setup.

1 Like

do you use a remote samba dc @Michael_Dahlgren_Nie ?

Yes, i have a WM Nethserver that is my remote samba dc

thank will try to reproduce, does WM is VM ?