Update to 7.5 release - Deep Packet Inspection (DPI) module is not available

dpi
ndpi
v7

(Christian Plaza) #1

what means this…: Deep Packet Inspection (DPI) module is not available
Restart the system and select a Linux kernel with DPI module support


(Marc) #2

Which kernel version is in use?

Check if you have the same problem as described here:


(Christian Plaza) #3

System version
NethServer release 7.5.1804 (final)
Kernel release
3.10.0-693.21.1.el7.x86_64

The same problem


(Marc) #4

Latest kernel is 3.10.0-862.3.2.el7.x86_64, but the updates could be blocked by another package. If yum update throws “Error unpacking rpm package python-backports-ssl_match_hostname” follow the instructions pointed on the other solved topic.


(Christian Plaza) #5

I make yum update but responde No packages marked for update


(Marc) #6
yum makecache
yum update

or if it does not work, clear the cache and try again.


(Pasquale Inglese) #7

The solution to the post is partial, only solves the problem with the update of the python-backports-ssl_match_hostname package. The problem with the DPI module has not been solved. The installed kernel is not compatible and yum has no kernel updates.

There must be some settings that create the kernel update problem but I can not find it.


(Marc) #8

Do you have subscription? Maybe the update is delayed due to that.


(Ralf Jeckel) #9

Installed a new NS 7.5 instance from iso today.
After update kernel 862.3.2 was installed.

nDPI module and basic firewall installation without problem. No subscription so long (will follow).
could create a rule with facebook-dpi without problem.
So I don’t think this is general problem of NS 7.5.

image



image


(Pasquale Inglese) #10

No! I don’t have a subscription!

If I look for the installed kernels I find the compatible version:

# rpm -qa kernel
kernel-3.10.0-693.11.6.el7.x86_64
kernel-3.10.0-693.11.1.el7.x86_64
kernel-3.10.0-693.17.1.el7.x86_64
kernel-3.10.0-862.3.2.el7.x86_64
kernel-3.10.0-693.21.1.el7.x86_64

I think it’s tied to a grub configuration but I’m not able to change it


(Marc) #11

@pasing, Did you reboot the server in order to load the new kernel?


(Pasquale Inglese) #12

Strange, I restarted it a few times only now it was successful.
Thanks for your patience and support, @dnutan!