Unable to restore / no restorepoint listed

NethServer Version: 7.4.1708 (Final)
Module: restore

Hi Everyone,

I am having some trouble with disaster recovery. I am unable to see in the Nethserver GUI restore section the previous backups I successfully made.

Here is what I did:

-Installed the same version of nethserver on another hardware (7.4) with the same IP and hostname as the old one.
-Logged in as root on terminal, ran yum update and rebooted the server
-Attached the USB harddrive where the full backup was stored (succesfully) every night at 3 by the old server
-Logged in to nethserver GUI, ticked “Skip manual configuration and restore a backup file” and uploaded the backup-config.tar.xz file with the option to install the necessary components. This went on quiet a while and finished successfully. I can see all users and components.
-Checked on backup section if the settings are the same as on old server -> yes, the usb is listed there.
-Clicked on restore section and the drop down menu to select the day I would like all files to have restored from, but realise only 1 day (today) is visible.
-If I run backup-data-list in terminal, it took quiet a while again but listed all the files but I don’t see them in the GUI.
-Turned off the server, starting the old server with the backup USB attached. Go to restore section and I can see the dates where successfull backups were made and also the file structure looks complete, not like this below:

Am I missing something? How can I restore to yesterdays backup, which I know was successfull?

Am trying to do the above procedure again on a different hardware. In case I face the same issue I will try the Command line procedure.
Could anyone tell me if I use the command:

restore-file / /

Will this recursivelly restore all files to its original place?

I’d recommend restore-data to restore all files, as restore-file is intended for selective restore.


1 Like

If I simply just hit the command restore-data as is, that would restore everything from the last backup?

Yes, it should take the last backup.

Thanks Markus, I will try that once the reinstall is finished on the other PC and report back.

1 Like

So far it looks ok. The data rstore is finished, without error, though there are some things missing:

-missing contacts and calendar
-missing mail filters
-All settings are back to default
-Customization missing
Software center:
-MySQL extension was not installed along with the webserver component
Restore files:
-Still does not list any previous backup point

I go through the server now and edit the list if necessary, or probably redo the procedure again to see if I was just unlucky.

If software is missing you may also try config restore again.

In nextcloud you have to reenable apps (also on updates) but work is in progress to save nextcloud settings AFAIK.

Sogo has an integrated backup/restore function, maybe it helps:


After a few tries, it seems the restore only works with the restore-data option. Nextcloud restore actually worked at the end wouthout any intervention, apart from enabling the apps manually. SOGo, and missing MySQL had to be done following your previous advise. Danke nochmal fuer die Hilfe Markus :slight_smile:

1 Like

The issue described above is consistent with my unsuccsessful tries to move from one server to a new server. Back-up seems to work fine including files in the /etc/backup-data.d/custom.include and .exclude file. I tried both: USB and CIFS. Also tried the config file on the backup and the config file from the source server. Restore from the UI was not possible at all. Only “restore-data” worked partially.

For example I miss files from custom.include and the definitions of some registered services (config setprop myservice status disabled).