Unable to reach nsdc - network problem?


I am running NethServer 7.7.1908 on a Intel NUC. This is a temporary situation. I am trying to migrate to a Hyper-V VM.

What I did is:

  1. Install NethServer 7.7.1908
  2. Install the updates
  3. Create a config and data backup on the original NethServer
  4. Changed the IP of the original serer (temporary)
  5. Disable DHCP (on the original server)
  6. Stop nsdc (NethServer Domain Controller container) (on the original server)
  7. Stop dnsmasq (on the original server)
  8. Restored config (new install)
  9. Restored data (new install)

I am able to ping the new install on the correct IP address (
I am unable to ping the nsdc ( from my network.
I am able to ping the nsdc ( from the console of the new install of NethServer.

I did look into the network settings and the firewall settings.
The bridge (br0) was originally bound to en01 (Intel NUC) and is now bound to eth0 (Hyper-V VM).
I can’t find any differences between the original and the new install firewall rules.

The physical port of the server which I use for the Hyper-V switch is connected to a unmanaged switch. The unmanaged swich is connected to a managed swich. The switch port is set to VID 300. Untagged traffic will be on VLAN 300.

I am hoping someone can help with this.

In the meanwhile I did set another IP on the new install of NethServer ( and I did stop DCHP and disabled nscd + dnsmasq on the new install. I did change the IP on the original install (NUC) back to and enabled the required services. Everything works fine from te NUC. I will shutdown the Hyper-V VM for now.

I understand that nscd is in a container. I am not sure how to trouble shoot the connectivity with the container from my LAN; I am able to ping nscd from the Nethserver’s terminal / console. My guess it is a network issue but I am not sure how to continue.

I did notice that I can view the users via “System” > “Users and Groups”. The Account Provider is set to “Local Active Directory”.


NethServer Version: 7.7.1908
Module: nsdc



AFAIK, in Hyper-V, as in VMWare, you need to enable the so called “promicious mode” on the NIC for AD to work correctly.

Proxmox doesn’t need any special treatment, works out of the box. I’d suggest looking at Proxmox - it comes with so many free features, like file backup for Windows and Linux, Clustering, fast Migration.
Best of all: you can even live migrate a Windows VM from an Intel CPU to an AMD, as long as Proxmox is installed on both, the VM migrates - and doesn’t even notice the different CPUs! :slight_smile:

You should urgently upgrade to 7.9!

My 2 cents


Thanks Andy,

I am running Proxmox at home. It’s nice. This server runs Windows Server 2019 with Hyper-V and I can’t change it to Proxmox.

What I did is follow your advice and applied the following via PowerShell:

Set-VMNetworkAdapter NET01 -PortMirroring Destination

$A = Get-VMSystemSwitchExtensionPortFeature -FeatureName "Ethernet Switch Port Security Settings"
$A.SettingData.MonitorMode = 2
Add-VMSwitchExtensionPortFeature -ExternalPort -SwitchName vSwitch01 -VMSwitchExtensionFeature $A

I will test this later as it’s 00:35 at the moment (and I am tired). But I’ll report back once tested. Thanks again.

1 Like

Hello Andy,

Thanks again. I was able to get NSDC up and running on Hyper-V.

I did some further reading and I did notice the following post:

I did notice in that post that I had to enable MAC spoofing and a recommendation to install the NethServer updates. Which I both did.

What I did change is the following:

  1. Recreate the Hyper-V switch
  2. Enable sigle-root I/O virtualization (SR-IOV)
  3. Apply the changes via PowerShell (see my previous reply)
  4. Enable MAC Spoofing
  5. Install all updates - now running NethServer 7.9.2009
  6. Test on two servers and two client computers