Unable to join windows 7 client to nethserver domain

dummies

#1

Hi there

I am able to ping NS server from win 7 client, win 7 clock synchronized well with NS server, and I have modified Win 7 client registry but still I am not able to join the client to NS domain.Error message in the screenshot below.

Any advise will be much more appreciated.


(Stefano) #2

domain is not in form of domain.tld

NS is a NT style domain, not an AD one


#3

Thank zamboni.
I have tried with domain name “home” as well with no luck.
based on your second comment, I believe I have some homework to do as I have no clue what is the difference between NT and AD domain ( I am just a dummy in this).

Thanks


(Artem Fedai) #4

Learn it and write for dummies :smile:


(Stefano) #5

can you please re post your images in a bigger size?

moreover: be sure your NS is the DNS for the client

finally, be sure to read carefully here:
http://docs.nethserver.org/en/latest/samba.html#primary-domain-controller


(Jose "Martin" Abeleira. AKA Marto) #6

DId you applied the registry options? i joined windows 7 and 8 machines to
nethserver domain.


#7

The first image:


#8

second image:


(Stefano) #9

thank you

be sure to read the documentation and follow the advices… apply the .reg patches and try again

let us know


#10

Yes I applied the patch as following:

  1. copied the Client registry setting
  2. pasted it in a text file using “Boc Note”
  3. saved as win7samba.reg
  4. double click on the file
  5. when completed, rebooted the win 7 client

But still no luck. Jsut in case, below the client registry setting I copied from NS:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanManWorkstation\Parameters]
“DNSNameResolutionRequired”=dword:00000000
"DomainCompatibilityMode"=dword:00000001

Thanks for your advise.


(Artem Fedai) #11

Are you using admin credentials while adding to domain?


#12

Yes I use admin credentials on the win 7 client


(Artem Fedai) #13

I think logs could say more , admin cred from NethServer you need while adding to domain


#14

Artem, Win 7 client does not show the dialog box for NS admin credentials. instead, I have message saying it is impossible to contact the domain AD. So I don’t even have the opportunuty to enter NS admin credentials.


(Artem Fedai) #15

Re enable domain service and check firewall on NethServer


(Roberto Sitzia) #16

@petralemoisson have you changed NethServer admin account password?

To join a Windows 7 client to NethServer Samba domain you must:

  1. on the client set just one DNS server IP address > NethServer green (LAN) IP
  2. on the client import registry settings for Samba domain
  3. on NethServer change admin password to enable this account and allow Windows to join the domain

(Artem Fedai) #17

@Sitz you see that win 7 does not request admin cred , so it could be firewall trouble as well


(Jose "Martin" Abeleira. AKA Marto) #18

Did it, i think i found what is happening.

Did you set admins password?

I’ve just joined my machine but i was triying to do it with root and didn’t
work out, set admin password and worked like a charm using admin user.

​


(Artem Fedai) #19

Grr @mabeleira we just have mentioned that need to use admin cred non root :slight_smile:


#20

I have tried with admin user instead of root, disable and renable with no luck.
One thing to add though is my network architecture is as follow

Modem ---->router 1(192.168.2.1) -----> to WAN NS server ( Lan NS 10.10.1.1) —>router2 (192.168.1.1) ---->windows 7 client wireless

Can this be the reason I can’t join NS domain ?