UEFI support of installation media not working

Tried to install NethServer 7 RC1 and RC2 from Optical Disc / USB Flash Drive on two computers in UEFI mode, and secure-boot either enabled or disabled:

  • NethServer’s boot menu didn’t show up,
  • CentOS menu shown, instead.

Selecting CentOS installation menu option ended with:

[ 151.669580] localhost dracut-initqueue[560]: Warning: dracut-initqueue timeout - starting timeout scripts
[ 215.534539] localhost dracut-initqueue[560]: Warning: Could not boot.
[ 215.664566] localhost systemd[1]: Received SIGRTMIN+20 from PID 562 (plymouthd).
[ 215.667797] localhost dracut-initqueue[560]: Warning: /dev/root does not exist
[ 215.688310] localhost systemd[1]: Starting Dracut Emergency Shell…
[ 215.732608] localhost systemd[1]: Received SIGRTMIN+21 from PID 562 (plymouthd).

Didn’t hit this problem when using a CentOS ISO.

The same with an EFI enabled VirtualBox VM.
On the VM it worked after editing the boot option from:

linuxefi /images/pxeboot/vmlinuz inst.stage2=hd:LABEL=CentOS\x207\x20x\86_64 quiet   


linuxefi /images/pxeboot/vmlinuz inst.stage2=hd:LABEL=nethserver quiet
1 Like

I can confirm this.
Honestly, I never found a server with UEFI boot :slight_smile:

I’m working on it, following this doc: https://access.redhat.com/documentation/en/red-hat-enterprise-linux/7/paged/anaconda-customization-guide/3-customizing-the-boot-menu

I’m wondering if we can release a RC2 without UEFI support (and create a bug for it), or we should wait.
I’d like to with the RC2 and release the RC3 in a short while with only this fix.

1 Like

I agree, our goals for the ISO could be

  • rc2: test new “legacy” short user names support, fix upcoming Samba issues

  • rc3: try to fix UEFI (btw in KVM I see a UEFI BIOS option, never tried)

Edit: rc3 could be based on CentOS 7.3!

1 Like

Github bug:

I have a working ISO for UEFI bios, but we tested it only on UEFI implementation of VirtualBox and KVM.

Have you got a little time to try it on the physical machine?
There’s no need even to wait for the installation to complete: if Anaconda starts to install the RPMs, then it will work for sure :wink:

This is a temporary ISO:

Thank you again for your time and work, I’m really amazed! :smiley:

Edit: ehi @quality_team, anyone wants to try it?
Also please make sure to have an hard disk of at least 20GB.


Not sure I can try it tomorrow, maybe next week.


On VirtualBox with EFI enabled

It works but once installed it shows this error at every single boot:

Don’t need to press any key, as it resumes by itself and finishes the boot process, showing the usual login prompt.

Probably it’s not relevant, but here is an excerpt of /var/log/anaconda/ks-script-oYQM4u.log :

/tmp/ks-script-oYQM4u: line 5: inst.stage2=hd:LABEL=nethserver: command not found
/tmp/ks-script-oYQM4u: line 5: inst.ks=hd:LABEL=nethserver:/ks/unattended: No such file or directory
/tmp/ks-script-oYQM4u: line 36: [: =: unary operator expected

Notice I did just try the install one time.
EFI partition was created successfully.

On real hardware

  • Install from CD/DVD:
  • Legacy mode: OK
  • UEFI mode with Secure Boot disabled: OK
  • UEFI mode with Secure Boot enabled: OK
  • Install from a USB drive (IIRC…):
  • Legacy mode: OK
  • UEFI mode with Secure Boot disabled: didn’t reach the installation boot menu
  • UEFI mode with Secure Boot enabled: didn’t reach the installation boot menu

The ISO image was burnt to the USB drive using dd. A second round of tests was made using ROSA Image Writer (just because it was handy).

If anyone else can test the USB install on real hardware with UEFI enabled it will be very welcome. :wink:

1 Like

Thank you, really excellent work!

Forgot to mention some errors… but not related to UEFI changes, I think…

On bare-metal the installation failed 2 or 3 times showing some python errors on anaconda installer.
I think anaconda is at fault for that. IIRC the installation continued after deleting the software RAID using another partition manager.

IIRC, these anaconda python errors also happened on v6.x, so UEFI changes are not the issue.

Also, once got a 4m[terminated] message and a sudden reboot when anaconda was about to install packages.
The next installation attempt succeded. Once at the login prompt I could ping to external sites, until shorewall came into play and logger errors appeared on CLI, losing Internet connection:

I think NetworManager has something to do with it.

RC3 resolves it