Trying to mount a shared folder - permission denied

v7
sharedfolders

(Pete) #1

Hi,

I’m trying to mount a shared folder from my nethserver on my Kubuntu system eith the following command:

sudo mount -t cifs -v -o username=testuser //ip-to-myserver/testshare /media/mountfolder

after inserting hte required password a get the message

mount error(13): Permission denied

When I connect via the KDE Filemanager Dolphin, everything works.

Any ideas?

NethServer Version: 7.6.1810
Module: your_module


(Pete) #2

I’ve found a way to connect:

sudo mount -t cifs -v -o username=DOMAIN\testuser //ip-to-my-server/testshare /media/mountfolder

But this works if I set the guest permissions to read & write only. When I restrict the access to the my connecting user, then it’s not possible to connect?


(Pete) #3

I found out that I have to mount the shared folder with some permissions set, otherwise I’m not able to create files and folders.

sudo /bin/mount -t cifs /ip-to-my-server/testshare /media/mountfolder -o user=local\testuser,uid=1000,gid=1000,file_mode=0660,dir_mode=0770,nounix

Is this the proper way to connect to a shared folder on nethserver?


(sam jonas) #4

Same happened with me… Thanks


(Giacomo Sanchietti) #5

You can mount it with something like:

 mount -o username=giacomo //192.168.1.1/iba1 /media/mountfolder

Just tested, it works. Instead of using the IP address it should be better to use the server name.


(Michael Träumner) #6

Did you forgot the option

-t cifs

or does it work without it?


(Giacomo Sanchietti) #7

It works anyway. :slight_smile: