Troubles Getting Started

So looking for some assistance here - I’m looking to make the switch from Sophos XG but I’m having some really stupid issues trying to get Nethserver up and running.

I can get Sophos installed and started without any issues so I’m not sure what I’m doing wrong or my approach.

First I’m trying to do an install on a mini PC that has 4 intel nics - this is a QOTOM machine that has no issues during the install. I manage to get Nethserver installed actually without any problems. Where i run into issues is when i plug in my WAN cable to port 2, and my Switch into Port 1 which feeds my AP.

It seems that its not grabbing any IP address for for my WAN, no is it serving up any IP Address for my LAN (so i can connect to my IP and access the web interface). I’ve also tried to access the IP address through the public one https://IP:980 but nothing comes up. I don’t have a monitor hooked up nor can i simply plug in a laptop in 1 of the additional NIC ports to hopefully pull up the web interface to do some configuration.

What can i do here? Sophos detected everything automatically - it was actually super simple.

Unless you installed the “old interface”, the URL to connect to the NS web interface is https://IP:9090
I would suggest statically setting your PC IP address to the subnet that you assigned your LAN interface on NS and then attempt to gain access to it that way.
Without knowing how you setup the interfaces on install it would be hard to know for sure what is going on, but I do know that during setup I had to set both network interfaces to AUTOSTART and then on the general tab click “automatically connect to this network when available" or they wouldn’t both come up on first boot.

I did write up a little migration guide for when I swapped over from PFSense, it might help for your Sophos migration.

1 Like


Hi Daniel

And welcome to the NethServer community!

As I do not know if QOTOM supports RHEL7 (NethServer is based on RHEL7/Centos7) - especially the Intel NICs. AFAIK, not all are supported by RHEL7/Centos7.

If Centos7 / RHEL7 will install on that box, and networking works, so will it work in NethServer.

NethServer does NOT make any claims about running on EVERY no-name box and supporting all / any NICs. Only about RHEL7/Centos7 compatibility…

It’s still possible to install NethServer, and add in the NICs later with a linux driver, but that’s more work. And screen (Even via Serial) would be a lot of help, instead of being blind, like now.

Best would be to inquire QOTOM, if RHEL7/Centos7 is supported (will install without issues) with their hardware…

My 2 cents

This doesn’t look very promising…


I’ve tested a QOTOM mini pc (I don’t know the exact model): ethernet cards from Intel worked nicely.

@Daniel could you find any error in the logs?
You will also find details about the configuration, something like:

/sbin/e-smith/db[6737]: /var/lib/nethserver/db/networks: NEW enp1s0=ethernet|gateway||ipaddr||netmask||role|green

It may help us help you.