Transparent proxy don´t block pages

webfilter
v7

(Christian Plaza) #1

NethServer Version: NethServer release 7.4.1708

Why when I put transparent proxy, don.t block the pages like facebook or youtube, the problem is when the page is https…

What I can do…?


(Markus Neuberger) #2

I tested it and it works with Chrome and Firefox. Which browser do you use?

Steps I did to block facebook.com:

grafik

  • Check if global blacklist is enabled in the filter settings:

grafik

  • Ensure that proxy is enabled and used by the client browser.

grafik

  • Check if there is some proxy bypass that may prevent the client from using the proxy:

grafik

  • Restart the browser on the client when testing.

(Michael Träumner) #3

@mrmarkuz What is about

Block HTTP and HTTPS ports

Is it only for manual and authenticated mode? If so, I would say it should be deactivated if transparent mode is chosen (Make sysadmins life easier :stuck_out_tongue_winking_eye:)


(Ralf Jeckel) #4

What about installing the dpi-module and block the specific protocolls via firewall-rule?


(Markus Neuberger) #5

It’s not relevant for blocking facebook. If you have transparent mode, traffic is redirected to the proxy so it’s not necessary to block the ports. When using manual/auth proxy you may use it to force use of the proxy and prevent internet from working without proxy.


(Christian Plaza) #6

Hi…

I use firefox, I will make the test. In firefox which of 3 option I mark…?


(Markus Neuberger) #7

No proxy and auto detect should work with transparent proxy.


(Christian Plaza) #8

ok I make the test.


(Christian Plaza) #9

Ok, I make the test and it´s works fine… block all that I want…

Thanx.


(Michael Träumner) #10

Hi @kristian1369,
could you mark the right answer as solution please.

@mrmarkuz Thanks for explanation