Transmission on nethserver


(Michele Bortolotto) #1

hi, i’m trying to configure transmission-daemon on nethserver, but i can connect to its webpage only on 127.0.0.1 (using elinks), are there something on nethserver that block incoming connection on 9091 ?


(Artem Fedai) #2

yep , make a new service and open port 9091 for RED, GREEN or BLUE zone


(Artem Fedai) #3

config set (name of the service) service TCPPorts 9091 access public status enabled
signal-event firewall-adjust
and you should see it on WEBUI :
Security => Network Services and could manage it as well


(leon) #4

Did a virgin install of Nethserver version 6.7.

How would you create a new service ? … which menu options would you take. In 6.7 I do not have any options to create a new service. I can only view the ones that were created through the installation of modules.


(Stéphane de Labrusse) #5

@AbsyntH the service transmission-daemon listen on the localhost only because apache does a reverse proxy to control who is connecting to the transmission webUI, let it to the localhost and use instead

https://IP-OR-HOSTNAME/transmission/web/

After that you can allow each users in the User Panel


(Giacomo Sanchietti) #6

You need to do it from the CLI.

http://docs.nethserver.org/projects/nethserver-devel/en/latest/services.html