Transmission error


I’m sorry I was still online translation

The transmission gives this error:

> 409: Conflict

> Your request had an invalid session-id header.

> To fix this, follow These Steps:

> When reading the response, its get-Transmission X-Session-Id header and remember it
> Add the updated header to your outgoing requests
> When you get this error message 409, resend your request with the updated header
> This Requirement has been added to help Prevent CSRF attacks.

But this is only for Mac OSX Safari under Windows with any browser.
Mac go under the Firefox and Chrome:

I do not see what could be? I deleted the browser history.

You have set up a Transmission torrent server within NethServer and this error appears when accessing the Transmission webUI using Safari from a Mac OS?

No server only client.

Based on this.

So far it worked without error. Today came out the error.
But Firefox works.

When it happened, the URL ended without a trailing slash?, like:

Some more (old) info can be found at:

Yes, I realize.
He missed a slash.
Sorry for such a trivial error. But we learn from this …

No problem. You’re welcome.

Can you have your torrent file automatically into the transmission?
Especially on Windows. I tried the browser ad-on, but not good

Really I don’t use it, but one thing that comes to mind is to create a shared folder to be watched by transmission, so when you download some .torrent file through the browser and save it to this network share, transmission will add it to its queue.

This was tested on NethServer 6.8

Stop transmission

service transmission-daemon stop

Edit transmission settings (use your preferred text editor, here it’s nano)

nano -B /var/lib/transmission/settings.json

On the settings.json file append a comma after the current last option. Then, before the closing curly bracket, add:

    "watch-dir": "/var/lib/nethserver/ibay/torrentwatch/",
    "watch-dir-enabled": true

where torrentwatch is the name of the share.

Apply the changes:

signal-event nethserver-transmission-save

Thanks, it works.

Interesting, I don’t use transmission like this but we can imagine to add it in nethserver-transmission

Thoughts please ?

According to the docs these are the related settings:

  • watch-dir: String
  • watch-dir-enabled: Boolean (default = false) Watch a directory for torrent files and add them to transmission.
  • trash-original-torrent-files: Boolean (default = false) Delete torrents added from the watch directory.

Out of the blue I can think of:

  • a checkbox for watch-dir-enabled (eg. Enable Transmission watch dir)
    • (optional) a text field or select/search box for the watch-dir
    • a checkbox for trash-original-torrent-files (eg. Move .torrent file to trash, or Delete .torrent file once added)

About the watch-dir share:

  • a) use a hard-coded watch-dir the administrator cannot change (no text-field, grayed out or hard-printed): maybe easier to handle permissions, as the current list of transmission users could be reused.
  • b) let the administrator pick and handle the desired ibay: administrator have control over access permissions (can set users but also groups…)
  • c) a mix of a+b: hard-coded share but created at install time as a standard ibay the administrator can manage.

Not sure if the subtle differences between option A and B are worthy.
Talking about ibays, but maybe some users would prefer to use webdav (eg. nextcloud?) or other access method.

1 Like

In fact with nethserver-transmission I provide a samba share to retrieve your download, you can of course change it accordingly( ${transmission}{DownloadDir}). We could imagine to put a directory of torrent watched file in this directory

1 Like

That’s a lot simpler, the KISS way. I like it.

the folder torrentwatch is created and added now for NS7 and NS6