The following command has failed: system-task/read

Hello to you all,

I’am new to Nethserver but already impressed with the posibileties.
however for now one little question, i keep ketting the following error in the server manager
“The following command has failed: system-task/read”
i ám using NethServer 7.7.1908
as a virtual server under windows server 2016 i am heaving that message from the start it also says

Unfortunately we couldn’t catch the exact error. If you want to help, please click on the button below to copy the failed command to the clipboard, paste it into the Terminal and submit command output to the developers. i can copy the command , but can’t get it into the terminal.

please give me a hand, thanks in advance
Reconnect (Paul)

In which page do you have this problem?

Hi federico.

i get the problem on the system -->dashboard and all of the other pages

thanks for the help in advance , could it have to do with rread and or write permissions ?

First of all, check forse updates

Hi federico.ballarini,
where can i find force updates In the server manager i cant get anywhere

Do you have access to the terminal (from the UI, from ssh/putty, or from the virtual server console)? From there you could use the copied command to get more info on the error, and also check for updates:

yum update

I have the exact same issue. If I try to login with the user I created during install (not root but another one), I get that error message. I ran “yum update” but the problem persists.

If there a solution to that problem?

Hi Patrick,

welcome to Nethserver Community.

What’s the result If you copy the command and run it in terminal?

I’m really not sure what is going on, right now I just can’t login. I can only ssh or password in with root. Is there a way to remove the user? I’m not sure if doing the usual linux removal is the way to go with Nethserver. Perhaps if I try to remove and add again. What is the procedure to remove and add a user?

OK I figured it out but I think this should be a bug. When I first installed Nethserver, I was asked to create a use, other than root. Root always worked fine but, my own user never did.

I didn’t create a LDAP or Active Directory until just now. I opted for LDAP since it was straightforward. Although my user was in /etc/passwd, when LDAP was done creating, my user wasn’t displayed. I created the same login name through the LDAP interface and that fixed the problem. I was surprised it let me do it since there should have been an error saying my user was already there.

1 Like

No, it’s not a bug, you need an account provider for having users.

What I am referring to as a bug is the fact that when you are installing Nethserver, it asks you to create a user which is useless unless you create a account provider (which I figured out yesterday). Why ask for a username creation during install if that wont work after? It is misleading and creates confusion.

Nethserver is based on Centos so anaconda installer is used. You are right, it is misleading in some cases.
User creation is not mandatory, it’s documented:

I see, thanks for pointing out the documentation. Any chance the installer could be modified in the future to at least point that out during installation that it is not mandatory or skip it all together? What I mean is, create a installer ?

It’s much work to create and maintain an own installer. I think it’s not worth the effort.

I guess I agree. I was just hoping it was flexible enough to introduce messages to advise people regarding this particular step of the process but… I guess not. Thanks for the help I appreciate it.

1 Like

I finally reproduced the problem. If I create a normal user without domain admins group access and login to the ServerManager, I get this message : [The following command has failed: system-task/read]

And when I click on the command that failed and go into the terminal, I get this :

/usr/bin/setsid /usr/bin/sudo /usr/libexec/nethserver/api/system-task/read | jq
sudo: no tty present and no askpass program specified


What version of cockpit do you use ?, I cannot reproduce.

Does the user is in no group at all ?

do an


your user must be a member of locals for ldap and domain users for samba AD.

I think it is tied to the user you have created during the installation

My thought as well, which is why I removed it. But now I’m facing other issues.