Testing the Samba Active Directory packages, samba does not authenticate users


I’m testing the new packages as per:

I’m able to create users and groups.
But when I create a shared folder, delegate it to a group, the user can browse but not login to a shared folder.

I searched all the logs without success, please advise.

Email works fine, on the nextcloud I had to change the server address from to the new DC IP address.


Hello @jfranco

if you use a domainname with a lenght below 15 chars, you sould be able to create a users and groups. I was testing very long names of domains. If I use a domain name blow 15 chars every thing is fine.
There was an issue about shared folders, but this should be solved with nethserver-ibays-3.0.1 by @giacomo
Look at this : Users unable to write on Shared Folder

Is your machine joined to the domain? If not, the credentials for login are workgoup\user + password AFAIK.

Did you check Allow write permission to owning group in edit shared folder? And you can try to add the user to ACL with read and write permission.


Hi @flatspin
Right on!

This works and fixed it for me!


1 Like