Testers needed nethserver-arm img

testing
arm

(Mark Verlinde) #21

that’s why it out there for testing, first impression is they behave very well.
Of cause, you will never be able to push a lot of traffic thought it.


#22

yes still here, only a lot of works in the past weeks and this week on holiday (with a poor connection)
i also forgot to told you that i have tested your latest image on a rpi3b+ and it worked flawlessly.

on monday i’ll put also on my mirror, and try to test mail2

probably i miss something but why not to directly use the “unofficial epel” of SIG arm32?


(Mark Verlinde) #23

Hi my arm companion, good to hear from you. :smile:

Did a loot of debunking on the rpi3b+ and comparted to the first image “it flights now”. :joy:

Nice, need help with that. If you taking it on drop me a note and i’ll share my curl-pits

Long time ago we discussed this here, and decision was we should “mirror”.
There is also an down side: the “unofficial epel” has grown a lot and “yum makecache” takes much time. The Software Center is snappier with a smaller repo. And by now I have a rude script which pulls the needed packages in.

Again nice to hear from you!


(Mark Verlinde) #24

Here is development image of nethserver-arm 7.5.1804 for RPI 2, 3 and 3+.

Tomorrow you get more info about the known issues, quirks and other things to do.

Upfront:

  • It’s development > no upgrade path to alpha >>>> final
  • The old mail(1) and mail2 package are both available you have to choose: you can only install one of them.
  • AD account provider is not possible, trying to install it throws an error without harm done.

grtz Mark

EDIT: (sorry)

Login : root
Password : Nethesis,1234


(Markus Neuberger) #25

Nice!

grafik


(Mark Verlinde) #26

As promised some more info on the Nethserver-arm 7.5.1804 development (image)

Until now the focus has been arm32, simply because the bigger audience. Experience from the past learned arm64 (aarch64) is quite easy to do. Proposal is to merge arm64 bit in at the first alpha release

Contribute and proposed workflow:
In the Software Center there are (“Everything” not counted) 5 tabs:

  • Base System
  • Firewall
  • Base in Development
  • Firewall in Development
  • Needs Work!!

Goal is to get everything out of the “in Development” tabs :smile: and as you probably guested:
if it’s in “Needs Work!!” there are already known issues. :sob:

If you :heart_eyes: to contribute you can adopt one or more modules and give them a good shake / tests:

  1. Does install without errors (log, and systemclt -f while installing are my friends here)
  2. Does function as expected
  3. How does it behave (memory usage, cpu usage) also over a period of days.

Known Issues:
Mail2: The filter-module (clamav anti-virus) is more embedded in the new mail 2 module, and imho pi’s do not have enough RAM to run clamav. The odroid HC1 with 2G it’s seems just to hold on on it’s teeth.

Nextcloud: Did not take on Nextcloud due to php7 requirement and unfamiliarity with it. There are some serious people working on php 7.2 for centos-arm32 and therefor do not think it’s impossible. If there is demand and someone adopts it for testing we can try to port it to arm32 bit.

AD accounts provider: technically possible not feasible. Did not take on the nethserver-sssd module and therefor the button is still there. It throws an error without harm done.

Get in touch:
You can ping me here, and in the coming days the arm-bugtracker will be updated (its 2 years old :astonished:)

Enjoy and happy to hear from you

Nethserver-7.5.1804-Devel-RaspberryPi-img.raw
Login : root
Password : Nethesis,1234


(Mark Verlinde) #27

Resreved for more known issues

wpa_supplicant is not installed: in an effort to make a clean image Network Manager including WIFI components are not installed; side effect is wpa_supplicant is not pulled in.


(Mark Verlinde) #28

What the hack,

if we are testing stuff and evaluating which Nethserver 7.5.1804 modules are feasible we can give SOGo a shake too :grinning:

After installing mail(1)
yum install --enablerepo=nethserver-testing nethserver-sogo

@Jclendineng


(Rob Bosch) #29

I was going through the history of these forums on education topics and stumbled on an interesting site mentioned by @filippo_carletti: Linux goes to school with NethServer
Just a reminder, maybe you can use the info.


(Markus Neuberger) #30

I noticed that the httpd server certificate is old after install.

I’d really like to have nextcloud on raspberry but

  • the php72 testing packages replace system php which has bad consequences i.e. roundcubemail depends on old php modules and won’t install
  • I had to change/delete package requirements in the specs file of nextcloud and nethserver-nextcloud, packages are here and on github if someone wants to try…
  • you’ll need unofficial epel, remi and the testing repo

Does nethserver-mysql work for you?

I could not login with root without password on command line which works on other Nethservers. But maybe it’s because of my tries with php72…


(Mark Verlinde) #31

Thankx for the feedback!

Will have an eye on this mine default self signed is valid to 2028

that is bad, we cant’s have that !! If you feel strong for getting nextcould i can try to get some info on the Arm-dev mailing list.

Ill gues yes, SOGo works: ill keep an eye on this too :grinning:


(Mark Verlinde) #32

Think we can have more luck with is repo:

https://armv7.dev.centos.org/repodir/community-SCLs_php72-testing/php72-php/7.2.8-1.remi/armv7hl/

examining one package it installs into /opt
....cpio\.\opt\rh\php72\root\usr\lib\httpd\modules\

Let me investigate, and we discus feasibility later
:+1:?


(Markus Neuberger) #33

SCL would be nice, remi-safe could be another alternative.


(Mark Verlinde) #34

Nice project! Saw it before and was on the breach on helping them a bit with user authentication.
(learning children it is oke to make a user/passw list in a calc sheet… :sob:)


(Mark Verlinde) #35

did i tell you i don’t know J@ck sh!t of PHP?

If we have this additional packages in the right place in /opt are we coming close than?

+Requires: php-fpm
+Requires: php-smbclient
+Requires: php-opcache
+Requires: php-pecl-apcu

(Markus Neuberger) #36

There might be some more modules like php-ldap or php-mcrypt but yes, we just need to make nextcloud use /opt/php-fpm instead of using rh-php72-php-fpm (which is just a TCP port configuration change) and it should work.
Maybe we could adapt nethserver-rh-php71-php-fpm in a way the /opt/ php version is used, then we could put the complete neth arm php 7 dependencies in one customized package and any neth php7 app should work, just an idea…


php72-SCL on RaspberryPI for Nextcloud
(Mark Verlinde) #37

Why not? At the end it are just binary’s in a flle-system and nextcloud has to find them…

Cross checking x86_64 nextcloud install against the “arm php 7.2.8 SCL” missing packages are:

-rh-php71-php-pecl-apcu      x86_64 5.1.8-1.el7        centos-sclo-rh       69 k 
-rh-php71-php-zip                 x86_64 7.1.8-1.el7        centos-sclo-rh       89 k
-rh-php71-runtime                 x86_64 1-1.el7              centos-sclo-rh       1.1 M
-sclo-php71-php-mcrypt        x86_64 7.1.11-1.el7      centos-sclo-sclo    19 k
-sclo-php71-php-smbclient    x86_64 0.9.0-2.el7       centos-sclo-sclo     36 k

rh-php71-runtime catches my eye, its big-ish


(Mark Verlinde) #38

nethserver-horde-0.0.1-1.16.gd07f9c5 is available in the nethserver(arm)-testing repository

to install it:

yum install --enablerepo=nethserver-testing,epel-pass1 nethserver-horde

note: No need to configure an extra epel repository
On 7.4.1804-Devel the epel-pass1 repo is configured in /etc/yum.repos.d/NethServer.ns-epel just not enabled by default. :wink:

cc @m.traeumner


(Michael Träumner) #39

Thanks for your work, but sorry I can’t test. I don’t have any Arm-PC


(Markus Neuberger) #40

Horde took some time to install but worked in first tests. :+1:

@mark_nl, I did some comments on your github issues, openvpn and web proxy.