System fails to boot following reboot after installing updates on 7/29/2020

I haven’t tried to recover my Netserver installation but on July 29 after it auto-installed 18 updates, I selected reboot and the system failed to get past the BIOS. It halts at the AMI Bios before booting. It appears that it cannot find the info needed to boot from the SSD (since I am not using either mail or file servers, I didn’t configure it with RAID).

I don’t have any mail or files I need to recover, and I will do some investigation in the next few days, but i am curious if anybody else has had a problem correlated with the recent batch of updates.

Hello @harry ,

I did these updates right now on two servers, one with RAID1 and one w/o RAID, both with SATA HDDs (both Intel barebone).
Everything works fine after reboot.


@GG-jr, thanks for letting me know. i figured I was the only one because nobody else posted any issues :frowning:

Sorry for your issue.
Maybe some info about the new kernel and your hardware (MB) on Google, can help.
The boot is UEFI?

I search on Google about issues with this kernel and I found some things …

Are you in this situation?

“Breaks reboot on old hardware set to use UEFI boot.
Works fine on new hardware set to use UEFI boot.”

I always use Legacy BIOS on old hardware …

The latest updated (7/29) crashed my nethserver guest on Hyperv 2019 too. Can’t ssh with putty. Looks like an issue with integration services since I can’t even see any boot message when I connect with hyperv manager console. No chance to get access to provide more details…

@GG_jr, Gabriel, I believe that is my problem. Setting the BIOS to do legacy boot gets beyond the American Megatrends Inc. (AMI) UEFI halt, but, of course, it can’t find a bootable image.

I have what by my standards isn’t really an old machine, It is a small motherboard with an Intel Haswell ULT i7 quad core (the public name is an i7 4600. It is in a fanless finned aluminum case. It is the slickest form factor box for a server like Nethserver I have found. It has 2 GbE ports and 2 HDMI ports. Internally it will take a 1 MicroSD, 1 2.5" SSD/Disk, and 2 mini PCIe/mSATA devices. It looks like one a Chinese manufacturer, Kansung sells, but i bought it slightly used where it had been used in an apartment building running, my guess, Linux with pfsense.

[added]: it is from a Chinese manufacturer, OotomTechnology Ltd, and they sell their products on Amazon. The motherboard part number is: Q4500UG2-H

1 Like

ruh roh

just so hard for me to turn auto updates on


had same issue solution is reinstall grub2 from rescue mod and re-create grub2 config file, you can follow below article steps to fix that.

I used Neth iso grub2-install give me error i am missing grub2-efi package, i don’t want to mess up my network setting (had bond on them) so downloaded grub2-efi rpm as same version as grub2 at another machine and install manually. then grub2-install and grub2-mkconfig solve my problem. Don’t forget to change Redhat texts to centos on article.


Emre, Thanks for the post. Would you please clarify a few things for me.

Which version of grub2-efi did you install? This one was updated about two days ago:

The howto you ited for CentOS/RHEL 7 to reinstall Grub2 from rescue mode also included grubw-efi-modules and shim. If you installed those, which versions?

I tried to install with yum, and got an error referencing yummain. Did you use yum or manually copy all the modules to the right places?

I am expecting more people to encounter this problem.

dear @harry,
please follow my steps to see if you need grub2-efi

  1. insert Neth/centos cd/usb and boot at Rescue Mode

  2. Change root directory with

chroot /mnt/sysimage
  1. Find your boot disk letter


  1. Try To install Grub2 in your boot disk
grub2-install /dev/sdx

(x is your boot drive letter mine is /dev/sda ) at this point if you get message said “installation finished. No error reported” you have to jump step 8. if you got error you are missing grub2-efi package follow step 5.

  1. Download & install grub2-efi package,i used grub2-efi-x64-2.02-0.86.el7.centos.x86_64.rpm. (i don’t remember if i download and install grub2-efi-x64-modules-2.02-0.86.el7.centos.noarch.rpm too) I downloaded at another machine and installed via usb drive.

  2. mount your external usb/cd and install with yum localinstall /xxx/xxx.rpm

  3. try to install grub2 again

grub2-install /dev/sdx

you suppose to get no error this time.

  1. use following commands to create new config file
grub2-mkconfig -o /boot/grub/grub.cfg
grub2-mkconfig -o /boot/efi/EFI/centos/grub.cfg
  1. Reboot your system.

i hope everything will work for you.
note: my system is Dell Poweredge R510 with sytem at hardware raid1 and data at hardware raid6

1 Like

Dear @neo,

Thanks for the detailed instructions. On my system I ended up doing a fresh install, then let it install all the updates, and it hung at the BIOS screen as it did before… I followed your instructions, installedgrub2-efi, and attempted to install the modules package, but it reported the same version was installed. I created the config file, and rebooted. It sill hangs. In the bios, I set UEFI OS first. If I instead set the bios option to boot centos instead of UEFI OS, then I get a grub prompt. Here is the sequence of the commands, and a shot of the BIOS screen (with centos as first boot as shown i get grub) grub2install biosscreen


Hi Guys!

I’ve been reading / following your problems and solution attempts.

I myself have been using VMWare since 1999 til about 2015, when I moved to Proxmox…

I’ve just finished updating all my 25-30 clients, all using NethServer as AD and more. All my clients run NethServer virtualized in Proxmox, for a few very good reasons…
I never had any such or similiar issues with Proxmox as Hypervisor.

Please have a serious look at running Linux on Linux, instead of running Linux on Windows - with headaches!

Advantages of Proxmox:

  • Completly free, you can license the support and “tested” update repos, but the cost is - compared to the competitors (MS Hyper-V, VMWare ESX, or Citrix XEN) very simple and cheap: It’s licensed per CPU socket (only). Cores are ignored where licensing is concerned! Only 4 price options for support, and I only use community support, it’s enough! You CAN run Proxmox without any support or license costs!
  • Live Backups of any running OS, including Windows (With Exchange or eg SQL-Server).
  • Live, fast Migration cluster, up to full High Availibility Cluster (Full-HA).
  • Only Hypervisor which can handle Full Virtualization (like the other three) but also Linux Containers LXC.
  • Can use ZFS or CEPH out of the Box.
  • Very solid and stable, needs maybe one reboot a year! Plenty of updates, but no reboot needed unless a new Kernel is introduced…
  • Easy migration / converting for VMs already running in another virtualization, eg Hyper-V -> Proxmox or VirtualBox -> Proxmox.

With Proxmox, it’s possible to backup a running VM (Live Backup) and restore that Backup on another hardware (completly different, eg AMD instead of Intel) - and no Microsoft licensing or reactivation issues! Proxmox virtualizes even the CPU (KVM Standard CPU), so a Windows system doesn’t detect any changes underneath. This is NOT possible with the others (Hyper-V, VMWare ESXi, XEN)!
I’ve restored a complete Hotel-IT (MS Server 2008R2 with SQL-Server) from a HP Proliant to a Mac-Mini, really different hardware, and no licensing issues or activation issues! This just as “proof of concept” to my client (and my business partner!).

There are good and valid reasons why Hyper-V isn’t used by many members on this Forum. We also have a few Xen fans here, and quite a few VMWare ESXi users.
But by far the most are happy Proxmox users! (Devs, Power Users, etc!).

A small test environment could be an older PC with at least 8 GB RAM - Proxmox is installed in 20 minutes…

See here for a few ideas:

If you have any questions, remember our forums motto:
The only dumb questions are those not asked!

My 2 cents


hello @harry,
did you make config file for MBR?

grub2-mkconfig -o /boot/grub/grub.cfg

Seems your system isn’t accept that fix for your hardware, you can revert-back update and wait for redhat/centos offical fix or use MBR instead of UEFI for your system since its already new.

Dear @Andy_Wismer,

Thank you for detailed Proxmox information and solutions, yes some time bare-metal have problems i agree with you.

1 Like


Microsoft’s Hyper-V has come a LONG way since they bought Connectix (With their Product VirtualPC). But having a complete Windows Server underneath, can’t really be considered “Bare Metal”… :slight_smile:

Still way too much overhead, the need for an Anti-Virus, commercial Backup Solution, etc…

Proxmox, VMWare and XEN are much closer to “Bare Metal” ideal.

My 2 cents

1 Like


Just a simple word of warning:

If you do try a test of Proxmox on halfway usable hardware (8 GB RAM, CPU with Hypervisor additions) you might get “hooked” as I did!

After 15+ years of VMWare, the decision to move came fast!
The benefits were too great!

Anyone ever seen a Windows 10 (virtual) PC with a 100GB NIC?
My Win10 PC and Windows Server, both running in Proxmox, are connected with 100 GB NICs!
Nice! :slight_smile:

My 2 cents

Dear @neo,

I think you have laid out the choices. I only touch a LInux machine at the shell level about once every 5 years, and I have to look up how to do even simple stuff like mount a USB drive. Thanks to your last response, I realize now that the Grub prompt means I can do a legacy BIOS install of Netserver.

Thank you.


Your feedback has been really appreciated through my efforts.

@Andy_Wismer Andre, I don’t want to hijack the discussion on the boot failure, but i agree with you about the advantages of a hypervisor. My experience overseeing a development team focused on data center servers going back to 2001/2002 was that even with just one VM guest, for the simple reason you could take snapshots of the VM and restore them with a few simple commands. I had read about Proxmox, but neither me nor my team has any experience. I might try it. Thanks for chiming in.

1 Like