Subscription Trial Pizza


(Yaroslav) #1

Hello!

I’m a newbie for NethServer.
I did a several reinstalls on my server and I have the same result:
https://m1.nethserver.com/stable/7.5.1804/base/x86_64/repodata/repomd.xml: [Errno 14] HTTPS Error 403 - Forbidden
I’ve followed this guide: http://docs.nethserver.org/en/v7/installation.html#install-on-centos and already have a subscription token.
Please help me.
What should I do the next?


(Marc) #2

Hi @jsisaev, have you followed the steps from http://docs.nethserver.org/en/v7/subscription.html afterwards?

If so, can you post the outcome of this command (anonymizing the Secret and SystemId fields):

config show subscription

(Yaroslav) #3

https://community.nethserver.org/t/subscription-trial-pizza/10628/2
Yes, I’ve already obtain the secret.

This is my subscription info:
subscription=configuration
XXXXXXXXXX=
AlertsAutoUpdates=enabled
AlertsUrl=https://my.nethserver.com/api/machine/
ApiUrl=https://my.nethserver.com/api/
InventoryUrl=https://my.nethserver.com/api/machine/inventories/store/
NsRelease=7.5.1804
PricingUrl=https://my.nethserver.com/?action=newServer
Secret=XXXXXXXXXXXXXXXXX
SystemId=265b08d1-1a6f-4370-bfe6-45b18617042b


(Marc) #4

Sorry for the delay, was setting up a trial subscription myself. Ended with the same error you reported.

Trying to access the repo directly gives the same forbidden message:
image

I guess the registration has not propagated completely to the remote servers. Either it will resolve by itself after a few minutes/hours or we should request revision.


(Yaroslav) #5

I faced with this trouble more than 1 day ago (I mean more than 24 hours ago).


(Marc) #6

OK, last time I tried a subscription (crostino) it took less than 2 minutes. I see some other user reported the same. Will ping some of the nethserver crew to see if they can help (but mind it’s out of office hours).

/cc @giacomo @filippo_carletti @alefattorini

Tried with:

signal-event nethserver-subscription-save
signal-event nethserver-subscription-update
signal-event software-repos-save
yum clean all
Loading mirror speeds from cached hostfile
https://m1.nethserver.com/stable/7.5.1804/base/x86_64/repodata/repomd.xml: [Errno 14] HTTPS Error 403 - Forbidden
Trying other mirror.

failure: repodata/repomd.xml from sb-base: [Errno 256] No more mirrors to try.
https://m1.nethserver.com/stable/7.5.1804/base/x86_64/repodata/repomd.xml: [Errno 14] HTTPS Error 403 - Forbidden

(Giacomo Sanchietti) #7

There was an error on the infrastructure, it should be fixed now.

So, just to be sure execute:

yum clean all
yum update

Thank you for reporting and sorry for the delay.


(Marc) #8

Working for me. Thanks