Still problems with nextcloud

NethServer Version: NethServer release 7.6.1810
Module: nextcloud

after solving the php problem I tried to add an user who isn’t a domain user therefore not in my AD. The result was I could not log in anymore and had to start over. I didn’t find any log with any Information /var/log/httpd/nextcloud_error_log, /var/log/httpd/nextcloud_log and /var/lib/nethserver/nextcloud/nextcloud.log are empty.

after removing nextcloud like descibed here: I reinstalled nextcloudwith the backends Software center.
I had the same php Problem, so I had to manualy set the line

<FilesMatch \.php$>

SetHandler “proxy:fcgi://”

to 9002.

  1. my Userpage downst show usernames (see picture)

  2. with the occ command I get the message “The current PHP memory limit is below the recommended value of 512MB.”

  3. I’m running nextcloud as virtual host. I can’t find any instructions how to apply the letsencryp certificate to this virtual host.

where are the php settings for nextcloud? I want to adjust the mem and upload values?

Maybe fail2ban blocked your IP after a few failed logins. Otherwise, try setting the user password a second time.

You can also check some other logs under /var/log/httpd and /var/opt/rh/rh-php72/log/php-fpm/

it might be a remainder of an older version (grep -r 9000 /etc/e-smith/, but don’t remove any entry). I’m running it from the first nextcloud version released by nethserver and haven’t faced the same problem.

You can specify the desired memory limit each time you run the occ command:

sudo -u apache scl enable rh-php72 -- php -dmemory_limit=512M /usr/share/nextcloud/occ

Adding the domain name to the letsencypt certificate domain list. It accepts multiple domains.

it shall be under /etc/opt/rh/rh-php72/php-fpm.d/ presumably at /etc/opt/rh/rh-php72/php-fpm.d/nextcloud.conf, depending on the php version in use.