Ssh login with remote account provider

Hi all,
I configured a neth7 with a remote account provider (openLDAP). Is there a possibility to use those accounts for ssh login ?

Yes it must works out of the box.

How can I check that?

Try to access your server by ssh using a user’s credential. It should work smooth

yes I tried that. I referred to the neth config. I installed authconfig to enable ldap, but it didnt work neiter.

Please don’t use any underlying upstream commands, configure the server using the web interface (or events and esmith db).

You can check the presence of all users in the slave machine using the web interface.
If you’re unsure, check with PAM:

getent passwd <user>@<domain>

If the user is visible and has shell access enabled on the master machine, you will be able to login.

Hi, thanks for your answer.
The user is shown in Management -> User and Groups in the webinterface. But it is shown as myuser@123.123.123. Using this account and your command results in
myuser@123.123.123:*:1015:502:My User:/home/myuser:bin/bash
I think this looks kind of good, because shows the user I configured in the remote LDAP.
The domain looks weird though, it is part of the server’s IP.
Any Ideas?

Something is wrong.
The user should be <user>@<domain>.

I don’t really know where something went wrong :slight_smile:

I uninstalled ldap, renamed the server name from the web-interface, renamed it back to the original and there it was again: the hostname = FQDN and now the users look ok after reinstalling local LDAP.
Problem solved, thanks for helping me!!!

1 Like