Squid Proxy / Web Filter


(Tohid Tamboli) #1

I m using squid proxy & Web filter.

Now the senario is [ I WANT TRANSPARENT PROXY!!..]

1:When proxy is set to manual – every things works proper -websites-are blocked redirected and all…
2:When proxy set to authenticated – asks username password for every new tab (su**)
3:When set to transparent – HTTPS sites are not blocked eg: facebook ,gmail.
4:When set to transparent with ssl – HTTPS sites do not show up there content at all says untrusted certificate.

I have downloaded shalla blacklists and also filtered it .

Can you suggest me trick or hack or way to achive my requirements!!!


(Vhinz Sanchez) #2

Hi @Tohid_Tamboli,

Pls. check out the query I recently raised. I have put there how I made it work. However, I do not have any authentication enabled so it might be different.

http://community.nethserver.org/t/proxy-configuration/741?source_topic_id=780

Hope it will help you somehow.

~Vhinz


(Tohid Tamboli) #3

vhinzsanchez: thank you very much !!!


(Tohid Tamboli) #4

You took me to a link that told me to auto detect proxy settings !
My settings on server side transparent ssl mode.
Browser set to auto-detect proxy
And the error on the browser is

Unable to find Proxy settings

for any site i request

but what settings were at server side ??


(Vhinz Sanchez) #5

Hello @Tohid_Tamboli,

My server settings are set to Transparent with SSL as well selected the tickbox on Block HTTP and HTTPS ports.

On client-side, try auto-detect as well as other settings. Try with different browsers as well so you can thoroughly check if the issue is server or client-side configuration.