Squid proxy requires configuration before it begins accepting proxy connections

v7
proxy

(Kenneth Kron) #1

Version: NethServer release 7.5.1804 (final)
uname -a
Linux neth-fw 3.10.0-862.11.6.el7.x86_64 #1 SMP Tue Aug 14 21:49:04 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

After installation the proxy server was not accepting requests until I performed the following actions.


(Markus Neuberger) #2

I wouldn’t consider this as a bug. If modules are installed you may enable them manually, it’s the same with web filter for instance.
It shouldn’t be necessary to enable the disk cache for clients to use the proxy.
In a way you are right, if one installs a proxy he most likely wants to enable it but in the case of a proxy you usually also want to configure it. In Nethserver enabling proxy is just a click so it shouldn’t be a problem.


(Rob Bosch) #3

Maybe there should appear a banner warning after installing the squidproxy that it needs to be enabled before it can be used. Just like after installing Samba4 AD accountprovider you see a warning to enable the admin and administrator accounts and in network when a GREEN interface is a DHCP client, to change it to static IP. (all with the links to the location in web admin interface.)