Squid Proxy and Software

v7
proxy
webproxy

(Nicola) #1

Hi! i’ve NS configured as DC with active directory. Proxy is configured by authentication mode and i set this in Internet Explorer connection under windows 10 clients.
I’ve a problem: in a client is running a software (Danea Easyfatt) that doesn’t permit to insert proxy parameters. i use this software to upload an xml file to my e-commerce website and update products, categories, price etc…when i launch the update danea tells me that is not connected in internet and check connection.

How can i solve this problem? i’m very novice about firewall and proxy…i’m learning…

Thank you all!


(Markus Neuberger) #2

Hi @nikoz83,

you may exclude the client in the proxy settings “Hosts without proxy”:

http://docs.nethserver.org/en/v7/web_proxy.html#bypass-by-source-and-destinations


(Nicola) #3

Hi @mrmarkuz
i can’t exclude the client because there’s a webfilter and i read that “hosts without proxy” work only with transparent proxy…right?

When i launch the update Danea software try to connect to 185.205.43.144

Thank you!


(Rob Bosch) #4

Just thinking out loud here. What if you change squid.conf (directly or through a custom template) and add an ACL that allows direct connection to that IP address?
something like:

acl bypass_list src ip1, ip2 etc,
http_access allow bypass_list

Could that work?


(Markus Neuberger) #5

In the content filter settings, you should disable “Block access to web sites using ip address”:

grafik

You may also try to add a firewall object host “danea” with the IP 185.205.43.144 and use “Sites without proxy” in the proxy settings.

You may try to disable “Block HTTP and HTTPS ports” to see if this is the problem.

http://docs.nethserver.org/en/v7/web_proxy.html#client-configuration

Where did you read that, I could not find it in the docs.


(Michael Träumner) #6

Which is your gateway address, your nethserver or your router?
If it is the router you can enter 185.205.43.144 as address without proxy at your internet explorer. For that go to proxy settings and click on advanced and at the exceptions list you have to enter the ip.
If you do so it doesn’t connect with the proxy.


(Nicola) #7

@mrmarkuz i solve the problem disabling “Block HTTP and HTTPS ports”. Perfect!! thank you so much!