Spotify offline only on mac

webfilter
webproxy
firewall

(nicola) #1

Hello,
why spotify (the client) works only on windows computers, while on a mac it continues to use the offline mode because it does not detect an internet connection?

in the filter, to unlock access to the spotify client, I used the option “Block IP access to websites” … if it is active, the client does not detect connection, if it is deactivated it works and I can listen to music. however this does not work on mac. what else can I do?


Cannot read gmail on macbook
(nicola) #2

I add that … using the home connection spotify works, while it does not work with the connection managed by the firewall


(nicola) #3

if, from this macbook, I connect to the site of spotify, here’s the error: “Safari can not connect to the proxy server kCFErrorDomainCFNetwork error 310”


(Michael Träumner) #4

How is your proxy configured? Transparent? If not, you have to set proxy settings at safari.


(nicola) #5

it’s set to manual for all zones and trusted networks, but it’s not just a safari problem but a spotify client / player


(Michael Träumner) #6

I think you have to set the proxy settings at the client also.

Is it using http or https? All other should bypass the proxy.


(nicola) #7

I have blocked the http and https ports in the proxy


(nicola) #8

I tried to set a proxy in spotify, entering the firewall address and port (3128) of the web proxy but this also works with client software (non-browser)?


(Michael Träumner) #9

If you set it at the spotify client software it should work for the client software.

Oh, I mean the spotify service, is this using http or https or an other protocoll?


(nicola) #10

it uses a peer-to-peer network


(Michael Träumner) #11

Hi @nicovon,
Sorry for the late response, I’ve had holidays for a few days. Did it work on mac without using a proxy?
I ask because it should bypass the proxy if not using a http or https connection and perhaps its blocked by firewall. If it doesn’t work without proxy also, you have to find out which port is used and you have to open it at the firewall.


(nicola) #12

are you talking about the internal firewall of the osx operating system? why on the other PCs with windows everything works, without the need to open ports?


(Michael Träumner) #13

No, I was thinking about the nethserver firewall, but you are right, this could not be the problem if it works at windows pc’s.
Could you choose the port or the protocol at the settings of spotify? A time ago I had a service by a customer of mine, where I could choose http if other protocols don’t work through a firewall. But I don’t know anymore if it was spotify.


(Renen Wasserman) #14

Are you using the Spotify application? if so, under preferences, “Show advanced settings”, all the way at the bottom there is a Proxy settings section which might be the missing link.


(nicola) #15

thanks, it worked! I chose http and then I entered the firewall ip and proxy port…

But now I have a problem reading the mail through macbook, through the mail app. unfortunately there are no proxy preferences to set


(Michael Träumner) #16

Have you set your proxy at network settings at the mac?

https://kb.netgear.com/25191/Configuring-TCP-IP-and-Proxy-Settings-on-Mac-OSX