[SOLVED] Unable to join W7 to AD/Esxi

activedirectory
v7

(!) #1

NethServer Version: 7.4.1708
Module: nsdc

Hello,

I have the problem that nsdc does not load samba AD correctly ay boot, i have to systemctl restart it.
Finaly i have :

Domaine maison.lan

NetBIOS domain name: MAISON
LDAP server: 192.168.65.114
LDAP server name: nsdc-neth1.ad.maison.lan
Realm: AD.MAISON.LAN
Bind Path: dc=AD,dc=MAISON,dc=LAN
LDAP port: 389
Server time: jeu., 08 févr. 2018 17:34:35 CET
KDC server: 192.168.65.114
Server time offset: 0
Last machine account password change: lun., 22 janv. 2018 19:12:03 CET

Join is OK
name: NETH1
objectSid: S-1-5-21-4113198553-124244608-273358729-1104
accountExpires: 9223372036854775807
sAMAccountName: NETH1$
pwdLastSet: 131611183234499820
dNSHostName: neth1.maison.lan
servicePrincipalName: HOST/NETH1
servicePrincipalName: HOST/neth1.maison.lan
whenChanged: 20180131184200.0Z
lastLogon: 131625812757299600
distinguishedName: CN=NETH1,CN=Computers,DC=ad,DC=maison,DC=lan

But no way to join the domain.
My W7pro wks got the admin credentials and whoof, the message “The network path has not been found” pop on screen.

Does anyone has a answer please ?
Thanks ans happy new year (didn’t said on this forum ;-))
Rémy.


(Bogdan Costin) #2

You have tried to read this resources? Maybe you can find info that will help


(!) #3

Thanks Ctek i’m working on it.
It must be Esxi garbage.
I gonna try to mount a new lab in one host (instead of 2).

To who it might interest, here the how to “Creating an isolated network between two virtual machines” in VmWare/Esxi host.


(Markus Neuberger) #4

Hi @Remy,

did you set up promiscuous mode on your vmware vswitch?

http://docs.nethserver.org/en/v7/accounts.html#installing-on-a-virtual-machine

The link you provided doesn’t work.


(!) #5

Hello MrMarkuz,
1.) Yep,
2.) Modified.
Rémy.


(!) #6

Well,
After deleting/re doing dozen of VM i quit with Esxi.
I donno why it didn’t work as it must do. Certainly a misconfiguration i wasn’t able to solve between my computers.

So i downgrading my lab and test NHS (> joke) with Virtualbox and my notebook and it works like a charm.

Aller, bon week-end !
Rémy


(fpausp) #7

Do you know - Proxmox - It may could be an alterative ?


(Markus Neuberger) #8

I am glad you got it to work with virtualbox. Just wanted to say that I actually run ESXi 6.5 with virtual NethServer as gateway with AD and some other services/apps and it works quite stable so basically NS should work on ESXi.


(!) #9

I used Pmox and it works nicely but as i had a free VmWare licence and want to learn Esxi i put it on my ml10.


(!) #10

Yes i thinks so, i don’t know what i’m doing wrong (for now -> bloody network manager & cards).