[SOLVED] Resetting a Forgotten Root Password

Hi all,

NethServer release 7.6.1810
Fully updated

I wanted to simulate a loss of the root password.

I followed the example on the page:


which is the same as:

except for: ‘rd.break’, ‘mount -o remount,rw /sysroot’ (which are equivalent to the above URL?) and the two exit commands at the end.

After a reboot, everything worked well to connect to the server at the console with the new password. Web console uses the new password.

But, with a PuTTY connection, I still have to use the old password!

Logged in as root at the console I used again the command: passwd and enter the new password. After that PuTTY worked well with the new password.

The only explanation I can think of is because of the use of LDAP?

Any other explaination?

Michel-André

The root user is not part of LDAP.

Hi Giacomo,

Thank you for your reply.

I changed the password twice following https://www.rootusers.com/how-to-reset-root-user-password-in-centos-rhel-7/

All is working fine now at the console, with PuTTY and at the web interface.

The above is not equivalent to the first way I tried. The above is working and the first way is not.

Michel-André

2 Likes