[Solved] Problems with nextcloud after June 2021 Update

NethServer Version: 7.9.2009 Crustino Subscription
Module: Nextcloud

today I saw new updates to nethserver available and installed them via cockpit:

nethserver-fail2ban.noarch 1.7.1-1.ns7
nethserver-mail-common.noarch 2.30.1-1.ns7
nethserver-mail-filter.noarch 2.30.1-1.ns7
nethserver-mail-ipaccess.noarch 2.30.1-1.ns7
nethserver-mail-server.noarch 2.30.1-1.ns7
nethserver-mail-smarthost.noarch 2.30.1-1.ns7
nethserver-netdata.noarch 2.0.2-1.ns7
nethserver-nextcloud.noarch 1.17.0-1.ns7
nethserver-unbound.noarch 1.1.1-1.ns7

The update process hung at “installing mariadb-nextcloud…”, I killed the pkgaction process, did “yum-complete-transaction” and “yum clean all” as I found in the forums.
Then, after a reboot, the service “rh-mariadb105-mariadb@nextcloud” was not running, I started it via cockpit but nextcloud told me, it was in maintanance mode.
As there are almost no active users in nextcloud (this nethserver is mainly used as email-Server) I decided to backup the users data and do a complete reinstall of nextcloud. (as shown here: https://docs.nethserver.org/projects/nethserver-devel/en/latest/nethserver-nextcloud.html#full-reinstall)

To make a long story short: now, after the installation of nextcloud via cockpit software center, I get the message: “The following command failed: system-packages/update”
echo '{"action":"install","packages":["@nethserver-nextcloud"]}' | /usr/bin/setsid /usr/bin/sudo /usr/libexec/nethserver/api/system-packages/update | jq

Nextcloud (Version seems to be running, I can login and bring the installation to an end.
But the integration into nethserver seems to be missing. No nethserver users in nextcloud as it was before, SQLite Database and the default nextcloud user interface.

Until now I did everything in the nethserver cockpit, now I don’t know how to go on, is it save to use nextcloud as it is or should I better try to install nextcloud without error message?

Hope anybody understands this novel

Can I ask you why? Did you check the process wasn’t really doing it’s job by migrating the database from old mariadb to the new one?
If you’re lucky enough, you should find the old dump inside the /tmp/ directory, the has a random name but you could quickly find it by size (it should be at least dozens of MB).

That doc is outdated, you need to remove also the new db.
I didn’t test it, but this should remove also the db under mariadb105:

scl rh-mariadb105 /bin/bash
mysql --socket=/run/rh-mariadb105-mariadb/nextcloud-mysql.sock drop database nextcloud
1 Like

In one of my installations it took 9 hours to migrate 9GB of database, so you just have to wait…

Hello Giacomo,
thank you for your answer.

Can I ask you why? Did you check the process wasn’t really doing it’s job by migrating the database from old mariadb to the new one?

No, I did not check, it just took very long (more than 20 minutes). Maybe I was too impatient.
There is nothing like a dump file in /tmp, but that’s not a big problem.

No I uninstalled nextcloud again via cockpit and tried your suggestions:

scl rh-mariadb105 /bin/bash

gives me: Need at least 3 arguments.

mysql --socket=/run/rh-mariadb105-mariadb/nextcloud-mysql.sock

I was able to connect to mariadb this way before uninstalling nextcloud in cockpit, but now it “Can't connect to local MySQL server through socket”.
Cockpit => Services shows " rh-mariadb105-mariadb@nextcloud" not running.

Oh, that’s long. And you knew before how long this could last?
For me it’s too late, I just try to reinstall.

No, but I’ve been bugging the technical support team a lot (it’s an enterprise installation).

Try with (not sure, I didn’t check, eventually see scl man):

scl enable rh-mariadb105 /bin/bash

You can try to execute: signal-event nethserver-nextcloud-update
If it doesn’t work, the installation needs extra love and time to hack on it.

never mind, poor reading comprehension, you said database and I was thinking storage… I don’t have a database that big…


Today, after another reboot yesterday that took longer than usual, I tried another install of nextcloud and voilá: it ended without error messages.
I am able to start nextcloud from cockpit without having to define a admin password or the database type. Looks like this time the installation went well.
Just the nethserver email-users do not exist in nextcloud.

OK, what I also did was this signal-event nethserver-nextcloud-update thing. It did not echo anything but maybe helped???

Thank you all.

My machine is however very old with SATA2 disks even if raid10. :+1:

1 Like

I confirm this bug:

echo '{"action":"install","packages":["@nethserver-nextcloud"]}' | /usr/bin/setsid /usr/bin/sudo /usr/libexec/nethserver/api/system-packages/update | jq

What is the real solution?



At the moment, you’re actually “Hijacking” an existing, solved issue…
No additional information (hardware / version / function).

Please open a new Post, with an appropriate titel, and add in some info as to versions, etc.

You have higher chances that someone will actually look at your issue, and help with a solution. At the moment, the post is considered “solved”, why should any look into your issue?


My 2 cents

1 Like

…and when you open the new topic Andy suggests, post an actual problem or question. You’ve posted a command, which tells us nothing. Describe what’s happening, and how (if at all) it differs from what you’re expecting to happen. We can’t read your mind.

This topic is closed as resolved.

1 Like