[SOLVED] No backup-data on console since 30.01.2019

backup
v7

(RoWiHei) #1

Hallo,
now I work at upgrade from nethserver6 -> 7
Once in a while I started backup-data on ssh-console, but since update at 30.01.2019 I saw this:
# backup-data
No name given at /sbin/e-smith/backup-data line 42.

# backup-data --help
/sbin/e-smith/backup-data version [unknown] calling Getopt::Std::getopts (version 1.07 [paranoid]),
running under Perl version 5.16.3.

Usage: backup-data [-OPTIONS [-MORE_OPTIONS]] [–] [PROGRAM_ARG1 …]

The following single-character options are accepted:
_ With arguments: -b_
_ Boolean (without arguments): -h_

Options may be merged together. – stops processing of options.
Space is not required between options and their arguments.
_ [Now continuing due to backward compatibility and excessive paranoia._
_ See ‘perldoc Getopt::Std’ about $Getopt::Std::STANDARD_HELP_VERSION.]_
No name given at /sbin/e-smith/backup-data line 42.

Bug or feature ? What can I do ?
I change each time the backup start in web interface as “workaround” - not so comfortable …:wink:
Thanks for every answer !


(Marc) #2

I think it is due to the migration to the multiple backups database done by a recent update.
The migrated single backup is named backup-data. You can use the backup name as argument for -b parameter (/sbin/e-smith/backup-data -b <name>).


(Federico Ballarini) #3

I had the same problem. Now the command is
db backups show
to see configuration of multiple backups

If u use only the backup created from server-manager you’ll see only one backup named backup-data

To start backup from CLI the command is
backup-data -b <name of backup>
In this case
backup-data -b backup-data


(RoWiHei) #4

Hallo, federico.ballarini
this was the answer I understand. But why this mystic syntax ? Don’t understand.
I tried hours with “backup-data -b servername” and much more, but this syntax I can’t guess.
Thank you !


(Giacomo Sanchietti) #5

The parameter after the b option is the name of the backup.
More info here: http://docs.nethserver.org/projects/nethserver-devel/en/latest/nethserver-backup-data.html#start-a-backup


(Federico Ballarini) #6

Hi @rowihei

These are the new commands to manage multiple backups with the new interface cockpit.
If u want to start a backup you have to do
backup-data -b <backup name> and not using the servername.

If u configure the backup from standard server-manager (port 980) you’ll have only one backup named backup-data and your command will be
backup-data -b backup-data


(Federico Ballarini) #7

Could you mark the answer as solution please? Thank you.