[Solved] Joining Nethserver to existing Win2008R2 Domain fails

NethServer Version: 7.7.1908

Hi there,

I am unable to join my freshly installed Nethserver 7 to an existing Windows 2008R2 AD Domain (Format: xxx.domain.de).
I installed Nethserver freshly on my ESXi Host and gave it two green Network Interfaces with static IP in the Subnet of the existing Domain.
Then i updated it fully and tried to join to my Domain. First Nethserver cant find that Domain Name but opens up the AD DNS Server. When i enter the IP of the DNS / AD Server he still complains but the second Time he is able to find it.
He then prompts me with the User/PW Credentials and i enter the 100% valid Admin Credentials that are able to join and manage the Domain on every other Host (Win7, Win10, Zentyal etc.) but here. No matter the Format (user@domain.de, domain\user, DOMAIN\user) he still claims that the credentials arent valid.
I already read all the Posts in the Documentation and on the Forums but im still too stupid to manage the domain join.
Sometimes the “Advanced Options in Accountprovider” are mentioned but i dont even see that in my Nethserver Webinterface.

Here is what i already tried:

  • reinstall Nethserver
  • try kinit from root cli
  • try domain join from cli
  • try modifying the krb5.conf to point to the right DC
  • restart it several times

Any Help (can only be something trivial i think) is appreciated

Edit: Just as i wrote this Post i realised i used the new Server Manager (that explains the missing Options) . Now he said join completed but doesnt let me in LDAP. Im currently trying some of the Suggestions on the Forums and hope that will work.

Edit2: After discarding the FQDN and providing the IP of the LDAP Server everything worked and i finally see the users.


Welcome to the NethServer community…

FQDN not working:
The problem is just a hint, that something with your DNS internally isn’t quite right…
Your NethServer may have to use the Windows AD DNS Server as DNS.

My 2 cents

1 Like

welcome to the community.
Could you please make a new post at this thread with your answer and mark it as solution like described at the following link…

So after trying out the old Server Manager and properly configuring the DNS there i was able to join the Domain. Turns out most of the Options needed are just not present in the new Server Manager, like setting DNS Server or setting Advanced Options for the Domain Join.

1 Like

You can set DNS Server for NEthServer from Cockpit…

Here is screenshot of the DNS option at cockpit.

Maybe @mitosisgag can share what he think’s missing on the DNS on Cockpit…

I did enter the DNS Servers there but it didnt work.
Just when i entered the DNS Servers in the old Server Manager under Network DNS it worked.
The Fields there stayed in Default Setting (first Google DNS second empty) until i entered it in the old manager.

Sorry my fault, these are the entries for DNS records.
Have a look at the dashboard, there you can change the DNS server.