SOLVED - Help! Suddenly no Cockpit! (EDIT: Browser issue?)

NethServer Version: latest
Module: cockpit

Today NS notified me there are some updates (postgreSQL)… so I tried to logon Cockpit to do it.
After login, white screen!
It seems to try to do something (see a couple of milisecond attempts to follow a link?), but just stays there. Not pending (no “wait to load” favicon), just left on a white screen.
I rebooted the server, same thing. Login screen and then white screen.
Pressing F5 to refresh the screen, reverts to login screen (so it never authenticated).

Console works.


EDIT: Wait for more info. I tried, using Chrome (which is same engine as Edge I used all the time before), and seems to work. Maybe some cookie problem. Will revert.

EDIT 2: Cleaning cookies etc. did NOT help. So there is an issue with this PC Edge (Chromium based) and Cockpit page. Note that Edge worked fine for many months on this page. Chrome on same computer, works on that page.

EDIT 3: PROBLEM IS WORSE. Same issue on another computer (not even on the same network), that could access NS GUI fine with Edge. Today, just white screen. So I am guessing we’ll hear about the problem more.

Any ideas?

Which version of Edge?
Did you reboot recently your windows computer?

Latest Edge on Windows 11 and I reboot frequently.

Actually the problem is worse (updated first post too), as it stopped working ALSO on a completely different computer. One is at home accessing my Nethserver locally, the other was at work over VPN.
Both were working fine before.

So either some NS update or some Windows update that both computers just did, broke it down.

Side suggestion: Firefox use a completely different HTML engine (not Blink from Chromium) and as a plus can be used as portable software, without any installation.

I’d go to a check with this kind of Browser. If it works (and some of the features don’t fully work, like backup config downloads or VPN configuration files download, already reported into the forum) could draw a line…

Works fine with Firefox except reported issues? Maybe something into Blink/Chrome/Edge is not working correctly on Cockpit, then in few days Cockpit Project will publish a patch.
Not working fine with Firefox? Well, more troubleshooting needed.

  • step 1: kernel version. if the output of uname -r is older than 3.10.0-1160.66.1.el7.x86_64 IMO could be worth to reboot the NethServer installation, allowing also an updated kernel to step in (unless is not advisable for other reason still not expressed here that I am not currently aware of)
  • step 2: restart cockpit. From shell with the command systemctl restart cockpit you can gracefully ask ther restart of the Server Manager
  • step 3: upgrade the security transport for Cockpit and NethServer. Currently I don’t know how to make it happen via shell, but there’s surely a way to setup an higher safety cipher for Cockpit (currently I’m using TLS Policy “2020-05-10 only TLS 1.2”) and restart cockpit from shell. I hope that someone who can provide a proper and safe way to change this config from shell. Consider also that this can generate some issues with older software interacting with NethServer, so this should be applied after toughtful consideration

Hope that these hints can help you troubleshoot this issue.

Thanks for replying. I don’t plan to use Firefox (which I left for Chrome years ago and then a few months ago switched to Edge), especially since Chrome seems to still work with Cockpit.
So whatever changed in NS or Edge, didn’t affect Chromium in general.

Anyway, as I said I have completely rebooted NS when this happened, so this fulfils both #1 and #2.
Kernel is exactly the version you mention.
Rebooted Cockpit, nothing changed.

I can see the GUI from my Chrome (in both computers), so if you know how to upgrade security policy via the GUI, let me know.

EDIT: I did try on Firefox btw, as Firefox is by default installed on my UNRAID server where NS is a VM. So I tried locally on the server with Firefox and it works. So it is “just” an issue with latest Edge and latest NS (not sure what was patched last).

Let’s see if it’s a single occurrence or it’s happening also on other installations.

sometimes browser console can give some clues about what is doing behind the scene.
Anyone dare to install Edge on Linux to try if it does the same?

EDIT: working with Edge 103.0.1264.37 on GNU/Linux

Edge 103.0.1264.37 working.
Chrome 103.0.5060.66 working.

Windows 10. Sophos Home as AV and content filtering.
Tested on two servers fully updated also with postgre updates (one of the last packages updated recently), one bare metal, one ESXi VM. Both installations with a valid Let’sencrypt certificate, both installation with the same TLS Policy (1.2 only… when a 1.3 available? :wink: )

103.0.1264.37 Edge here too.
I wonder if it is some (common) extension that does the problem.
I will try to run Edge “safe”.

EDIT: Edge to run in safe mode, is simply running a “private” window. I did and guess what: IT WORKS.
So something in “normal” Edge (maybe some extension) does this issue. But who knows what extension updated yesterday?

No extensions on both browser for my test.

Found the offender:
Extension called “Context menu for Google Translate”.
Not sure if it is in combination with some other extension, but disabling that one (and only that one) solves the problem.

End of alarm. Thank you all for helping!