[SOLVED] Cannot access WebTop via https://mydomain.tld/webtop after removing the virtual host option

Hello everyone,

Please help me to solve the following problem:
I had installed WebTop5 with the “Use a virtual host for WebTop” option, access being done through https://webmail.mydomain.tld.
Due to some problems that occurred when obtaining the Let’s Encrypt SSL certificate, I de-selected the option to use via virtual host, at the same time changing the Public URL to https://mydomain.tld/webtop.
After this change, I can no longer access WebTop from the WAN except through https:/mydomainIP/webtop.

For Nexcloud I made the same change without problems.


Which error do you get in browser?

Is the public URL in the server manager Webtop advanced settings correct?

Hi @mrmarkuz ,

It’s no secret, it should be https://gtbs.ro/webtop.

Yes, it is.

https://your_external_IP/webtop/ is working so it’s about using the domain name.

Let’s check if there’s a virtualhost overriding webtop:

httpd -S

[root@host-gtbs ~]# httpd -S
VirtualHost configuration:
*:80                   is a NameVirtualHost
         default server host-gtbs.gtbs.ro (/etc/httpd/conf.d/virtualhosts.conf:12)
         port 80 namevhost host-gtbs.gtbs.ro (/etc/httpd/conf.d/virtualhosts.conf:12)
         port 80 namevhost support.gtbs.ro (/etc/httpd/conf.d/virtualhosts.conf:73)
         port 80 namevhost www.gtbs.ro (/etc/httpd/conf.d/virtualhosts.conf:167)
         port 80 namevhost gtbs.ro (/etc/httpd/conf.d/virtualhosts.conf:261)
*:443                  is a NameVirtualHost
         default server host-gtbs.gtbs.ro (/etc/httpd/conf.d/nethserver.conf:41)
         port 443 namevhost host-gtbs.gtbs.ro (/etc/httpd/conf.d/nethserver.conf:41)
         port 443 namevhost host-gtbs.gtbs.ro (/etc/httpd/conf.d/ssl.conf:56)
         port 443 namevhost support.gtbs.ro (/etc/httpd/conf.d/virtualhosts.conf:24)
         port 443 namevhost www.gtbs.ro (/etc/httpd/conf.d/virtualhosts.conf:118)
         port 443 namevhost gtbs.ro (/etc/httpd/conf.d/virtualhosts.conf:212)
         port 443 namevhost collabora.gtbs.ro (/etc/httpd/conf.d/zz_collabora.conf:9)
ServerRoot: "/etc/httpd"
Main DocumentRoot: "/var/www/html"
Main ErrorLog: "/etc/httpd/logs/error_log"
Mutex rewrite-map: using_defaults
Mutex authdigest-client: using_defaults
Mutex ssl-stapling: using_defaults
Mutex proxy: using_defaults
Mutex authn-socache: using_defaults
Mutex ssl-cache: using_defaults
Mutex default: dir="/run/httpd/" mechanism=default 
Mutex mpm-accept: using_defaults
Mutex authdigest-opaque: using_defaults
Mutex proxy-balancer-shm: using_defaults
PidFile: "/run/httpd/httpd.pid"
User: name="apache" id=48
Group: name="apache" id=48
[root@host-gtbs ~]# 


(maybe is expected)
it explicitly forwarded me there even if I input https://gtbs.ro/webtop.
webtop.gtbs.ro has no public address, gtbs.ro and www.gtbs.ro have the same ip address.

IMVHO nethserver installation should have public FDQN.

https://host-gtbs.gtbs.ro/webtop/ is working.


I think you override webtop with your virtualhost because the server domain is used in the vhost. You may try to disable the virtualhost and test if webtop works…

Hi @pike ,

When we used the “Use a virtual host for WebTop” option, as for Nexcloud, we had a DNS registration as webtop.gtbs.ro (cloud.gtbs.ro).
Without these options, those records are no longer needed.

from here i cannot resolve that hostname, using sgurgle DNS.

1 Like

Which virtual host?

In /var/lib/nethserver/vhost I only have gtbs.ro (wordpress) and support.gtbs.ro (OsTicket).
host-gtbs.gtbs.ro is the name of the machine on which NethServer is installed.

You’re right, from another server I can’t ping or resolve it.
I think I get a cached result from unbound.

I deleted this record from DNS.
Normally, it shouldn’t have been…

1 Like

Please try to disable the wordpress gtbs.ro virtualhost just to test if webtop works afterwards.
Usually the virtualhosts shouldn’t use the server domainname that the other apps are using too.

gtbs virtual host is now disabled and it works.
So, what should I do now?

Good question but I don’t really have good answers:

  • Use another domain name for the NethServer apps like Nextcloud and Webtop but changing server domain name means reinstalling account provider.

  • Use another domain name for the Wordpress virtualhost.

  • Use a vhost for Webtop again but other apps may have similar issues.

  • Use the wordpress module and browse to https://gtbs.ro/wordpress

reinstall webtop with gtbs virtual host disabled could it be a solution?

No, I don’t think so. After enabling the gtbs vhost, webtop won’t work.

I just installed SOGO with gtbs.ro virtual host disabled, I activated it after installing virtual host: SOGo

Also Nextcloud is working but Webtop doesn’t, I don’t really know why.
You could try to reinstall webtop but I don’t think that it can work using the same domain as the wordpress virtualhost.

When I installed webtop for the first time, without using the virtual host option, it worked with gtbs.ro/webtop.
I activated the virtual host option for webtop and it worked very well with webmail.gtbs.ro until I disabled virtual host for webtop.
What would be the best procedure to uninstall webtop completely (webtop, tomcat, postgres) and try to reinstall webtop from scratch?