SOGO Mail Deletion Bug?

Hi All,

I’ve set up a new mail server and installed sogo as it seemed the easiest fit for my old exchange users to adapt to, however I’'ve noticed that mails cannot be delted through the sogo interface.

It works perfectly with IMAP I also installed roundcube to compare and can delte them through there as well it’s just sogo that has the issue.

I’m fully updated to the latest version and problem exists on all mailboxes.

Hi James,

I tried different browsers and had this problem only on Firefox.
Edge, IE, Opera and Chrome worked.
Can you please check?


So: what are the extensions used on Firefox?

Great catch! Thanks @pike !

@jcp2mill I deactivated my extension and it worked.
Then I reactivated all extensions and it still worked. :smile:

PS: I changed the category to Support, as it’s not a nethserver issue.

Which is the extension flawed?


Thanks for the replies I’m afraid it’s not so simple for me I just tried using Opera (for windows)
and Firefox with extensions disabled and am still having the same issue.

It does work in Edge though …

Sorry I don’t know.
I disabled the 2 extension I use (AdBlock and Keep) than enabled both again and it still worked to delete mails in SOGo. But I think it was rather Keep then AdBloack, because Adblock was disabled an my nethserver-pages.

I think I’m just going to stick with roundcube, my users won’t ever get off the phone if I tell them they need to use certain browsers or disable extensions. :grinning:

I cannot reproduce, I use FF 69.0.1 on linux and plenty of plugins, this should be reported to the sogo bugtracker

Same here. Can’t repoduce anymore using FF 69.0.1 on WIndows after disabling an reanabling extensions.

Into Private Browsing?

Sorry haven’t had a chance to check this again, I’ll check it out as soon as I get a chance.

HI All,
Tried this on a linux machine as well and had the same results didn’t try turning off the extensions but actually after a bit more playing around webtop is fine for my needs so as far as I’m concerned this isn’t really an issue anymore, unless anyone else wants to keep it open?