SOGO Email - Change the default from email sender


#1

Hi I’m a new user of NethServer and Discourse so I’m sorry if I’m missing something obvious.

I’ve set up a server to try as replacement for Zentyal and also saw your write up in Linux Voice.

Set-up was very easy and the extra features are great.

Everything in users and email address I understand (I think) but I’m stuck on an option for a new user.

I would like to be able to set the default “from” address used in SOGO but I see no way to change this.

I have 3 domains listed

adomain.com (family)
bdomain.com (work)
local.domain (internal)

I set up new.user and make sure to unselect “Create default email addresses” then create 2 external email addresses

new.user@adomain.com
new.user@bdomain.com

Once this change shows to the user the “from:” dropdown shows both valid email addresses.

How do I make new.user@bdomain.com the default?

I thought this might be under User Preferences > Mail Options or in the Services section of the user panel but can’t see an option to edit the selection order in either of these places.

Is there a way to do this either per user or for the server as a whole?

Thx

Dave


E-mails got send from wrong maildomain
(Giacomo Sanchietti) #2

It’s a SOGo bug and there is no way to workaround it.
See http://www.sogo.nu/bugs/view.php?id=768 reported from @alefattorini.

If you don’t need the groupware part, try roundcube!


#3

Thanks, I’ll give that a look.