SOGo calendar in Thunderbird/Lightning problem

sogo
thunderbird
lightning

(Rob Bosch) #1

NethServer Version: 7.4
Module: SOGo

I have SOGo installed on my NethServer on a VPS. Mail is configured as per instructions in the docs. Now I run into a weird problem.
I have chosen to use Samba4 AD account provider and created several accounts.
Now I want to use the calendar functionality in SOGo and have it available in Thunderbird/Lightning.
In SOGo I allowed my calendar to be shared with my wife’s account, aswell as her calendar is shared with my account.
When I log into the webinterface of SOGo and head over to the agenda, I can see both calendars. When I log in to my wifes account on the webinterface, she can only see her own agenda.
Now I added the agenda’s in Thunderbird/Lightning and for my agenda it seems to work (I can access it and add/change/delete entries in myn own agenda) but my wife’s agenda has a small yellow triangle which states: agenda is not available at the moment.

I triple checked both accounts and they have 100% the same configuration. I am at a loss here. Any ideas how to come over this?

The only thing I can find in the logs that is particular different between being logged in on my account vs being logged in on my wifes’s account is in sogo.log. When I am logged into SOGo webinterface with my wife’s account, I see these lines occuring a few times:

2018-02-01 20:22:12.514 sogod[8508:8508] ERROR(-[NGLdapSearchResultEnumerator nextObject]): does not support result references yet …
2018-02-01 20:22:12.581 sogod[8508:8508] ERROR(-[NGLdapSearchResultEnumerator nextObject]): does not support result references yet …


(Stefano Zamboni) #2

Your best bet is to check on sogo’s bug tracker


(Rob Bosch) #3

Just doing some weird things here and looks like I solved my own problem. :joy:

When opening Lightning extention page in Thunderbird and rightclick the bogus agenda, click “reset Calendar Cache” and everything is great…
Just noticed this option is only on Linux version of Thunderbird. Not in the Windows version… :-/

almost pulled out my last hair on my head…

@Stefano_Zamboni: thanks for directing me “somewhere north-east” …


(Mark Verlinde) #4

does not support result references yet …:confused:
Tried to figure this out looking in the SOGo soucre code, have not figured it out jet:disappointed_relieved:

Up coming week(s) attention will shift to SOGo in a attempt to help

Short Dutch chat: Ik heb nog steeds wat tijd nodig om SOGo opnieuw te leren kennen.


(Michael Träumner) #5

I’ve had a similar problem with SOGo. I shared a calendar and tried to connect to it with caldav synchronizer. It always said, calendar not reachable. At SOGo webinterface I deleted the share (not the calendar) and added the user again, after that it works without any problems