SOGo again: LDAP not working

I think my Sogo can’t login to ldap anymore. Just stopped a couple of days ago.
Funny enough, sometimes Outlook loads mails, so it seems to work sometimes.
Running current Nethserver version, with all updates
There are just a few error messages in sogo.log:
Feb 28 14:17:20 sogod [26015]: <0x0x55968ed0a520[LDAPSource]> <NSException: 0x55968f03a9f0> NAME:LDAPException REASON:operation bind failed: Invalid credentials (0x31) INFO:{“error_code” = 49; login = “samaccountname=xxxx,dc=ad,dc=mds4u,dc=local”; }
I have several other program that use LDAP and they all work.
There are several similar bug reports in the web, but none could help me.
The same thing happend one year ago…

The error is because of invalid username or password.

You may test your AD server with ldapsearch. Check out this wiki article.

I am afraid it’s not that easy…
LDAP worked fine.
I solved the problem by restoring an old config.
Now everything works again.
Last year I reinstalled my server, but I’ve learned…
The question is, what happened in config that produced that effect, we will never know.

Can you compare the sogo.conf file that is working against the one that isn’t working?

1 Like

sogo.conf are identical.
The Problem must have been LDAP/Samba.
In the server manager I got a sssid generic error, which is gone after I recovered the old config.

Restoring configs really works good…
Now I will save all config files so I can get back when that effect happens again…

1 Like

Maybe check sssd debug log to find the error:

Please also check logfiles in /var/lib/machines/nsdc/var/log/samba/* for more information.