SOGO, AD and mailbox

sogo
activedirectory
v7
mailserver
mail

(Stefano Zamboni) #1

Hi there

NS7.3, sogo installed, successfully joined a w2012r2 AD domain, users can log in in sogo without issue…

the only issue I’m having is that once logged I have no mail folders and a single message on the background “no mailbox selected”

I guess it’s something I have to setup on windows… any hint?
TIA


(Stefano Zamboni) #2

I have no dirs in /var/lib/nethserver/vmail other than root and vmail (empty)


(Markus Neuberger) #3

Hello @Stefano_Zamboni,

I hope I understood you right.
You have to setup nethserver-mail-server.
Did you expect that you see the mails from an Exchange server when connecting to AD?


(Stefano Zamboni) #4

yes, I have nethserver-mail server module

and no, I have no exchange server… I want to offer mail services to my domain users

I see my domain users in web server manager interface
I can login in sogo with domain users creds
I can use outlook to login to ns with domain users creds

I don’t see any vmail dir created for any user


(Markus Neuberger) #5

Maybe the user has to receive an e-mail.
I tried it with administrator user who wasn’t in vmail dir.

[root@server ~]# ls /var/lib/nethserver/vmail/
admin@cmb.local   root                 vmail
markus@cmb.local  shared-mailboxes.db  vmail@cmb.local

I sent him an email

and now he has a vmail dir.

[root@server ~]# ls /var/lib/nethserver/vmail/
admin@cmb.local          markus@cmb.local  shared-mailboxes.db  vmail@cmb.local
administrator@cmb.local  root              vmail

(Stefano Zamboni) #6

thank you for your answer

it was an error on my side… since it’s a test, I redo everything and now it’s working as expected


(Jeff Swank) #7

I’m having the same problem and I have no way to send a user an email yet. What was the “error on your side” and how did you fix that?


(Markus Neuberger) #8

Hi @Socs28,

you may send an email via command line:


(Jeff Swank) #9

Thank you, I realized that, tried it and it didn’t work, but I’m not sure if the email just didn’t go to the right place or if the mailbox didn’t get setup anyway. Either way it didn’t get me where I need to be.


(Markus Neuberger) #10

What about using the pop3 connector for testing a mailbox. You can download mails from some gmail account to a specific user mailbox. Don’t forget to set “Delete downloaded messages: Never”.

http://docs.nethserver.org/en/v7/pop3_connector.html


(Jeff Swank) #11

Thank you, I will try that.


(Jeff Swank) #12

I tried this and it does not create the mailbox. The maillog says it delivered the mail, but there is not mailbox created in /var/lib/nethserver/vmail.


(Jeff Swank) #13

Also, I am getting this
mail dovecot: imap-login: Disconnected (auth failed, 1 attempts in 12 secs): user=cw@wma.local, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, secured, session=<fmpeoONonAB/AAAB>

in my /var/log/imap file


(Markus Neuberger) #14

Has the vmail folder correct rights and owner vmail?

[root@server2 ~]# ls -l /var/lib/nethserver
drwx------  8 vmail  vmail  152 Mar 25 21:44 vmail

You may send a mail from one local user to another with roundcube and check if it works and post the relevant part of /var/maillog.

Please provide your installed packages to check your mail server implementation and if somethings missing…

rpm -qa nethserver-*

Seems like cw@wma.local logged in with wrong credentials.


(Jeff Swank) #15

cw could log into SOGo, but could not log into round cube. I’d like to figure out how to make this work, but for now I have decided to setup a local AD and will administer users in 2 places as I needed to get this up and working. I couldn’t log into roundcube with any users.


(Markus Neuberger) #16

You may have a look at /var/log/roundcubemail/errors.log.


(Jeff Swank) #17

This is the error I’m getting:

[30-Mar-2018 00:10:43 +0000]: IMAP Error: Login failed for cw@westernmerc.com from xxx.xxx.xxx.xxx. AUTHENTICATE PLAIN: Password: in /usr/share/roundcubemail/program/lib/Roundcube/rcube_imap.php on line 197 (POST /webmail/?_task=login?_task=login&_action=login)


(Markus Neuberger) #18

This is a typical error of wrong username/password so you may try to reset the user password and login again.

Is your account provider working? You may test it with

account-provider-test


(Jeff Swank) #19

Unfortunately I have had to move on from this. The account provider was working to authenticate SOGo. If I am able I’ll try this again on a vm sometime.