Sogo ActiveSync disabled

,

sogo ActiveSync does not work after removing webtop5
I solved it by performing these steps:

config setprop Sogod ActiveSync enabled
signal-event nethserver-sogo-update

3 Likes

Can you reproduce it please ?

And see if the value ActiveSync is set to disabled before to launch the signal-event

config show Sogod

I have both WebTop5 and SOGo installed on the same machine.

If I run config show for both, I have:

[root@ns7 ~]#
[root@ns7 ~]# config show sogod
sogod=service
    ActiveSync=enabled
    AdminUsers=admin
    Certificate=
    Dav=enabled
    DraftsFolder=Drafts
    MailAuxiliaryUserAccountsEnabled=YES
    Notifications=Appointment,EMail
    SOGoInternalSyncInterval=30
    SOGoMaximumPingInterval=3540
    SOGoMaximumSyncInterval=3540
    SOGoMaximumSyncResponseSize=2048
    SOGoMaximumSyncWindowSize=100
    SentFolder=Sent
    SxVMemLimit=512
    TrashFolder=Trash
    VirtualHost=
    WOWatchDogRequestTimeout=60
    WOWorkersCount=10
    status=enabled
[root@ns7 ~]#
[root@ns7 ~]#
[root@ns7 ~]# config show webtop
webtop=configuration
    ActiveSync=enabled
    ActiveSyncLog=LOGLEVEL_ERROR
    DefaultLocale=en_US
    DefaultTimezone=Etc/UTC
    MaxMemory=1024
    MinMemory=512
    PublicUrl=
[root@ns7 ~]#
[root@ns7 ~]#

I think this article must be updated with the new informations if what @netbix said is confirmed.

Something like this (or better):

Warning: If both WebTop5 and SOGo were installed on the same machine and one of them is removed, ActiveSync must be verified and enabled for the remaining groupware:

To verify ActiveSync on SOGo:

config show sogod

To enable ActiveSync on SOGo:

config setprop sogod ActiveSync enabled
signal-event nethserver-sogo-update

To verify ActiveSync on WebTop5:

config show webtop

To enable ActiveSync on WebTop5:

config setprop webtop ActiveSync enabled
signal-event nethserver-webtop5-update

PS:
I don’t know if it is a bug.

This is my configuration only with sogo

[root@sogomail ~]# config show sogod
sogod=service
ActiveSync=enabled
AdminUsers=admin
Certificate=
Dav=enabled
DraftsFolder=Drafts
MailAuxiliaryUserAccountsEnabled=YES
Notifications=Appointment,EMail
SOGoInternalSyncInterval=30
SOGoMaximumPingInterval=3540
SOGoMaximumSyncInterval=3540
SOGoMaximumSyncResponseSize=2048
SOGoMaximumSyncWindowSize=100
SentFolder=Sent
SxVMemLimit=512
TrashFolder=Trash
VirtualHost=
WOWatchDogRequestTimeout=60
WOWorkersCount=10
status=enabled
[root@sogomail ~]# config show webtop
webtop=configuration
ActiveSync=disabled
ActiveSyncLog=LOGLEVEL_ERROR
DefaultLocale=en_US
DefaultTimezone=Etc/UTC
MaxMemory=1024
MinMemory=512
PublicUrl=

I removed and reinstalled webtop5 All packages

I now have this situation:

[Root @ sogomail ~] # config show Sogod
Sogod = service
ActiveSync=enabled
AdminUsers=admin
Certificate=
Dav = enabled
DraftsFolder = Drafts
MailAuxiliaryUserAccountsEnabled = YES
Notifications = Appointment, EMail
SOGoInternalSyncInterval = 30
SOGoMaximumPingInterval = 3540
SOGoMaximumSyncInterval = 3540
SOGoMaximumSyncResponseSize = 2048
SOGoMaximumSyncWindowSize = 100
SentFolder = Sent
SxVMemLimit = 512
TrashFolder = Trash
VirtualHost =
WOWatchDogRequestTimeout = 60
WOWorkersCount = 10
status = enabled
[Root @ sogomail ~] # config show webtop
webtop = configuration
ActiveSync=enabled
ActiveSyncLog = LOGLEVEL_ERROR
DefaultLocale = en_US
DefaultTimezone = Etc / UTC
MaxMemory = 1024
MinMemory = 512
PublicUrl =

ActiveSync is enabled into both, correct?

According to this

http://docs.nethserver.org/en/v7/webtop5.html#webtop-vs-sogo

yes, ActiveSync is enabled on both, but “SOGo will take precedence”.

"WebTop and SOGo can be installed on the same machine.

ActiveSync is enabled by default on SOGo and WebTop, but if both packages are installed, SOGo will take precedence."

EDIT:

Can you reproduce the issue that you found after you remove WebTop5, as @stephdl suggested?

Will you run config show sogod after remove WebTop5, without any other commands, to see if ActiveSync for SOGo remains enable?

TIA,
Gabriel

1 Like

I removed webtop5 and ActiveSync sogo remains active. I have tested before and after my ipad with exchange account and it works.
Thanks for your patience. Sorry
This is not a BUG

OK!

Will you mark this topic as SOLVED on @stephdl response, please?

TIA,
Gabriel

Problem solved
Thank you

It is not a matter of patience, we are here to hunt bugs…the issue you hit should be written to the wiki of sogo like @GG_jr found it in the documentation.

If you can have a go Gabriel.