SOGo 3 - 502 Proxy Error

I’ve just installed SOGo3 on Nethserver 7 alpha 2 and getting an “502 Proxy Error” instead of logon scree.
There is an exception in SOGo log:

Apr 27 22:00:15 sogod [2078]: <0x0x7f9fcb733c90[SOGoCache]> Cache
cleanup interval set every 300.000000 seconds
Apr 27 22:00:15 sogod [2078]: <0x0x7f9fcb733c90[SOGoCache]> Using
host(s) ‘’ as server(s)
EXCEPTION: <NSException: 0x7f9fcbe2a390>
NAME:NSInvalidArgumentException REASON:init with obj and key arrays of
different sizes INFO:(null)
Apr 27 22:00:15 sogod [1333]: <0x0x7f9fcb9c1630[WOWatchDogChild]>
child 2078 exited
Apr 27 22:00:15 sogod [1333]: <0x0x7f9fcb9c1630[WOWatchDogChild]>
(terminated due to signal 6)
Apr 27 22:00:15 sogod [1333]: <0x0x7f9fcba32b80[WOWatchDog]> child
spawned with pid 2099

It should be solved in SOGo 3.0.3 as stated here:
enter link description here

How can I update SOGo to this version on Nethserver?

@GG_jr @robb @Nas @mark_nl @chrisg @Miko10 do you have thoughts on this topic?

Today I have installed NS7a2 on a dedicated hardware, for testing.
I intend to test it as PDC/AD + urbackup with FreeNAS as storage.

Tomorrow I will try to install SOGo package to see if I can to reproduce this issue.

@pelo: can you give us more details about your configuration to try to reproduce your issue (where is NS positioned in your network, how is configured: acting as …, which modules are added, what language do you use, …)?
Try to set NS on English and test again, in case did you set another language. Could be because you use special characters.


I had some issues with some software because of “Region” settings on the desktop. Works only on English …


1 Like

@pelo, is the language of your browser Swedisch?

IF SO, the answer is in the description of the link;

Set your browser to an another language
Edit /usr/lib64/GNUstep/SOGo/MainUI.SOGo/Resources/Swedish.lproj/Locale
and add (somewhere between “{ }” )
NSAMPMDesignation = (AM, PM);
Wait for SOGO 3.0.3, this is still not released;
You could install it from SOGo’s nightlybuild repository by adding that repo to /etc/yum.repos.d/

Personally i would go for option “2”…

A cross post (sorry @GG_jr), the language of SOGo default’s to the Browser, i’ve addressed that @SOGo some years ago; there is an setting in sogo.conf for that witch is “ignored”; and only used if the browser language can’t be sourced.


Don’t worry! We all are here “To serve and …” help!


Hi Lumir,

I have installed just email packages, for NS 7a2, in English, after full updates.

I cannot reproduce your issue.

I’m convinced that your issue comes from language settings, as we (@mark_nl and/or me) have described above.

Kind regards,

1 Like

thank you for your prompt responses. On the first tries, I installed the NS in “interactive mode” and set it to my time zone…but after I ran into this issue with SOGo, I install NS in “unattended mode” so everything was in defaults. After installation I simply completed the startup wizard, install packages - Email, POP3 connector and SOGo, nothing else. Then install updates ant tried to run SOGo and ran into “502 Proxy issue”.

I am installing into ESXi, not in production yet, so there is no problem to install it as many times as I want. VM is connected to LAN and hostname is “neth.localdomain”. There is no DNS server for “localdomain” so I must replace the hostname in browser by NS’s IP adress. I tried webtop and owncloud on this instance and they are working flawlessly.

And now some funny - I reproduce similar error on sogo demo site :laughing: ( The first time I login as “sogo1” user and left everything in default. The next time I switched the language in SOGo login screen to “Slovak” and got Proxy error. This setting was saved to this user, so I must switch manually to “English” to login there. So it really looks like language issue. I am using “Slovak” language in browser so I am going to install NS once more and play with languages in browser and give you a feedback. But on my NS I am getting “Proxy error” instead of login screen, so I will try to set language in my browser too.

And I have another question about POP3 connector - fetchmail. What is the status of this module? Is it working, working with issues or not working at all? I want to bring one NS to my production and really like SOGo v3 interface (on demo site) so is it safe to install NS7a2 or it is better to install NS6.7 for now and switch repo to nightly updates to install SOGo v3 on it?

So it regards your language :slight_smile: please fill a bug on sogo but tracker
About the pop3 connector can you open a new one? So we can keep this discussion on topic?

Hi Lumir,

NS7a1 is the developing stage and is not proper for production.
We must wait at least NS beta1 for this.

You can use NS 6.7 final for production but I’m not sure how easy will be the upgrade to NS 7 and if will be possible because of the major changes of the NS 7. @davidep and @giacomo can tell more about that.

AFAIK, with NS 6.7 final, @Nas made an upgrade for SOGo to the last version and has worked. You can find more about this, here:
SOGo 3 is released


The “Swedish” Bug applies for a lot of languages, including Slovak:

1 Like

I assumed only simple response like: “it is safe” "or “don’ use it yet”.
So as @GG_jr said, it will be better to use NS6.7 in production for now with updated SOGo and wait for stable release (and trying to help you with testing NS7 meantime). I hope it will be possible to update NS6.7 to NS7 then…

Of course! You’re welcome! Thanks for your time.

1 Like

SOGo 3 is alive on my server! I don’t know whatever I’ve done to this NS instance, but it is working now. I am going to make a clean installation once more and try to find where was the issue…