Software Center Stuck: [Errno -1] repomd.xml signature could not be verified for virtualbox

NethServer Version: NethServer release 7.7.1908 (final)
Module: Software Center > Virtual Box

I tried to install Virtual Box and it got stuck with this error:

failure: repodata/repomd.xml from virtualbox: [Errno 256] No more mirrors to try. [Errno -1] repomd.xml signature could not be verified for virtualbox

The install/update may have failed due to metadata caching issues. Please clean the cache by clicking the button below and retry the install/update operation.

I clicked the button many times, but this warning is still stuck there. Furthermore, it prevents the software page from being used at all. I saw this during testing as well, and at that time I just re-imaged the machine and started over. I’m nearing going into production, so I can’t be re-imaging each time something gets stuck like this.

Is this a known issue? Is there a solution for it?

You found a bug. Solution for you would be to run a yum check-update from command line and accept the key fingerprint for the virtualbox repository (or follow instructions from virtualbox for RPM-based Linux distributions).

When installing phpVirtualBox from software center (nethGUI or cockpit) the virtualbox repo is enabled but the public key is not accepted without user intervention.
On NethGUI a red banner shows the errors described by @djx. On both NethGUI and Cockpit, software center remains blank, blocking the user from installing any module (and maybe any update).

virtualbox/7/x86_64/signature                            |  181 B     00:00     
Retrieving key from
Importing GPG key 0x98AB5139:
 Userid     : "Oracle Corporation (VirtualBox archive signing key) <>"
 Fingerprint: 7b0f ab3a 13b9 0743 5925 d9c9 5442 2a4b 98ab 5139
 From       :
Is this ok [y/N]: n
virtualbox/7/x86_64/signature                            | 2.9 kB     00:06 !!! [Errno -1] Gpg Keys not imported, cannot verify repomd.xml for repo virtualbox
Trying other mirror.
1 Like

“no” was answered. No GPG key imported, no packages downloaded from Oracle…
Maybe the answer should be y?

It was just a way to illustrate or explain the problem from yum (not an example of the solution), sorry if it was confusing.

thank for reporting it, we worked on it, possibly I still have a bug on it, but at the moment I think the problem comes from the 7.7 repository

so in short I miss these versions in 7.7 repository

cc @giacomo (we miss last version of phpVirtualbox in 7.7 repository

I believe I also experienced this issue when I was testing against 7.6. As a general question though, can Nethserver add better handling for this type of error? It seems that fixing the Virtualbox keys will fix it now, but it may happen again (or some other yum issue) in the future. It would be good if this didn’t completely break the “Software” page.

1 Like

I pushed a fix in September for this, maybe you tested before, I hope :slight_smile:

1 Like

I just tested with the new version I pushed to 7.7 repository, and it should works as expected