Software Center Empty

Hum… Well, normally, your problem is this one:

Symptom: When you install or search for any package with yum, you get the following errors:

removing mirrorlist with no valid mirrors: /var/cache/yum/i386/6/updates/mirrorlist.txt
Error: Cannot find a valid baseurl for repo: updates

This error can happen due to yum metadata issues. To fix this problem, clean up yum data including metadata and local cache.

$ sudo yum clean all

So tomorrow, when you will have access to the server, after a good coffee, give a second chance to this command. :grinning:

in a root terminal you don’t need the sudo part and moreover a correct answer should be

yum clean all --enablerepo=*

Thanks guys. I’ll give this a shot in the morning when I can gain access to the appliance to reboot it.

Did you tried to run yum manually from console ?

yes, he did…
@all: please

  1. read ALL the messages before posting :wink:
  2. avoid print screens and images…

thank you

Thanks for this.

Curious… why?

I’m curious too, why? :smile:

Still the same problem after running this. :frowning:


Show us your In /etc/yum.repos.d

And your yum.comf

Is little gif accepted? :joy:

Edit: This is the nethserver.repo, since it’s the only repo file with enabled repos:

# YUM repositories configuration

name=CentOS-$releasever Base

name=CentOS-$releasever Updates

name=NethServer $distroversion base 

name=NethServer $distroversion updates

name=NethServer $distroversion testing

#  This is the default, if you make this bigger yum won't see if the metadata
# is newer on the remote and so you'll "gain" the bandwidth of not having to
# download the new metadata and "pay" for it by yum not having correct
# information.
#  It is esp. important, to have correct metadata, for distributions like
# Fedora which don't keep old packages around. If you don't like this checking
# interupting your command line usage, it's much better to have something
# manually check the metadata once an hour (yum-updatesd will do this).
# metadata_expire=90m

# PUT YOUR REPOS HERE OR IN separate files named file.repo
# in /etc/yum.repos.d

I will verify with mine… I found strange the # before the baseurl…

Take a look if the cache dir already exist.

I uncommented the baseurls in the nethserver.repo file for centos-base and centos-updates and it appears to be working now… weird.

Comparing the nethserver.repo file to a few other installs, the baseurl options should be commented out. So does anyone have any thoughts about what happened and why?

because I can’t cut and paste text from an image to try to reproduce the issue…

images are a bad thing in this case…

no, cut and paste, thank you

Just put the image in Acrobat and OCR it if your typing skills aren’t up to par.

I kid, of course. :wink:

On that note, check out the following screenshot. It shows that the problem is still there and uncommenting the base urls was just a work-around:

Text added for @zamboni

yum update
Loaded plugins: changelog, fastestmirror, nethserver_events, presto
Setting up Update Process
Loading mirror speeds from cached hostfile
YumRepo Error: All mirror URLs are not using ftp, http[s] or file.
 Eg. Invalid release/
YumRepo Error: All mirror URLs are not using ftp, http[s] or file.
 Eg. Invalid release/
 * nethserver-base:
 * nethserver-updates:
No Packages marked for Update

thank you

every time “we” use CLI, we should just copy and paste here command, results and error messages…

images are good for UI, not for debugging

Makes sense to me.

You should have a forum title of “Forum Nazi” or something. You seem to always be the one setting people straight, whether people are veering from the preferred NS roadmap or posting incorrectly. :smiley:

no, you’re wrong

since we are not in fron of the “problematic” server and everybody here is trying to help in his spare time, I think that we all should help the others to help…

in other words, if you (generally speaking) think I (generally speaking) will re-type all the error messages and commands (to try to reproduce the issue or just to search with google), well, you (generally speaking) are wrong…

moreover, using a CLI makes cut and paste the text so easy that you (generally speaking) have no reason to create a screenshot and upload here… and, remember, trying to read and understand what is wrote into a minipicture (using my smartphone) is quite difficult…

this is no a nazi approach, this is almost 15 years in helpdesk (starting from usenet and going trought may, many forums)


Maybe you took what I was saying the wrong way. I’m almost always in agreement with what you have to say, I was just joking around referring to other posts I’ve seen by you in the past. Rather than having to go digging through the forum quoting all of your prior comments that I’m referring to which will even further derail this thread… nevermind.

Let’s try to understand the problem. :smile:

@Adam, could you show the output of yum repolist -v ?

Mine is:

Repo-id      : centos-base
Repo-name    : CentOS-6 Base
Repo-revision: 1438723315
Repo-updated : Tue Aug  4 23:24:45 2015
Repo-pkgs    : 6,575
Repo-size    : 5.4 G
Repo-baseurl :,,
Repo-mirrors :
Repo-expire  : 21,600 second(s) (last: Thu Nov 12 16:07:02 2015)

Repo-id      : centos-updates
Repo-name    : CentOS-6 Updates
Repo-revision: 1447188368
Repo-updated : Tue Nov 10 21:48:54 2015
Repo-pkgs    : 652
Repo-size    : 3.3 G
Repo-baseurl :,,
Repo-mirrors :
Repo-expire  : 21,600 second(s) (last: Thu Nov 12 16:07:07 2015)

Repo-id      : nethserver-base
Repo-name    : NethServer 6.7 base
Repo-revision: 1445525368
Repo-updated : Thu Oct 22 16:49:32 2015
Repo-pkgs    : 446
Repo-size    : 417 M
Repo-mirrors :
Repo-baseurl :
Repo-expire  : 21,600 second(s) (last: Thu Nov 12 16:07:09 2015)

Repo-id      : nethserver-updates
Repo-name    : NethServer 6.7 updates
Repo-revision: 1447256812
Repo-updated : Wed Nov 11 16:46:53 2015
Repo-pkgs    : 22
Repo-size    : 30 M
Repo-mirrors :
Repo-baseurl :
Repo-expire  : 21,600 second(s) (last: Thu Nov 12 16:07:09 2015)

repolist: 7,695
1 Like