SMTP relay sub domains

Neth Server - 6.8 Final

Hi Folks,

First post, so apologies if this is in the wrong place. I need some help with setting up the e-mail side of Neth.

Ok so our scenario, we have one domain name ABC.COM for example. Neth is configured to route mail destined for mailboxes to this domain to itself i.e. ME@ABC.COM routes to a local mailboxe and everything works like a charm :slight_smile:

So I now need to setup a MailTrain newsletter / mailing list server on a separate box. In order to detect ‘late stage’ bounces MailTrain uses VERP and I have setup a SUB DOMAIN of BOUNCE.ABC.COM. We are limited to 1 external IP so my hope was to use Neth to accept mail for this sub domain (I’ve set the MX record etc) and RELAY any messages received to the local SMTP engine on the MailTrain server. So I setup a ‘relay to other host’ for ‘BOUNCE.ABC.COM’ in the e-mail section.

Everything works from a DNS routing perspective i.e. ME@BOUNCE.ABC.COM arrives at the Neth server however instead of accepting the mail and routing to the MailTrain box the message is bounced with a ‘Recipient address rejected: Access denied (in reply to RCPT TO command)’ error.

Any thoughts would be much appreciated.

1 Like

I haven’t tried but… maybe…:

Go to Email -> Domains and clic on "Create New"
In “Domain” field put “” (without quotes)
click on “Relay to another server” and put the address of the newsletter box in the empty field below.
Click on “Submit” button

1 Like

Thanks for the reply, very much appreciated.

Sadly that’s exactly what I did.

It’s as if the tertiary sub domain ‘bounce’ is being ignore and a match is being made against ABC.COM and hence the server is trying to match the recipient against its local accounts.

I tried setting up a 2nd domain XYZ.COM and relaying this traffic to the MailTrain box and that worked fine, lending weight to my suspicion.

1 Like


I tried on my Nethservice 6.8 (it’s a enterprise release but I don’t thing that is important) adding a third level domain ( to my domain (

I relayed to an IP of my network.

I sent from gmail a mail to and in the /var/log/maillog I see that mail I sent is tried to route to the ip address that i added as relay.

Please, try again and check /var/log/maillog if the mail is routed correctly

1 Like

Hi @Simon_Slaytor
have you tried what you suggested @saitobenkei?

1 Like