SMTP Protocol Error: 501 5.1.7 Bad sender address syntax when sending mail from our printer through Nethserver

NethServer Version: NethServer 7.9.2009


Nethserver and all apps (mail and webtop) is fully updated.

On my printers I have the ability to send email alerts for various warnings and above. In the printer

The only input I have on the printer to send an email through my Nethserver are the following fields:

SMTP Server -
Return E-mail Address -

Enable SMTP Authentication:
Username - myuserid
Password - •••••••••••••

When I try and send a test email I receive the following error message on my printer:

SMTP Protocol Error: 501 5.1.7 Bad sender address syntax

What would I need to input into my printer SMTP settings page that would allow me to send email from my printer through my Nethserver mail?

Thank you.

Could you please provide printer model and firmware version?
In recent years I never found so few settings about SMTP into several printers (mostly Brother, Kyocera and clones, Xerox, Canon).
At least port specificatin, SSL or TLS, sender, authentication method are options available from ten years.

1 Like

Good points @pike !

My model is an older HP Laserjet P4015 printer. There is no option to add a port or any type of security which is surprising.

Which firmware version is installed?

Whoops! I forgot to include that. I’ve installed the latest firmware available from HP (from 2017):

20170124 04.270.2


Which according to the Readme file is the latest available for the product.
Would you please consider to post the screenshot of the setting page? In english language…
Did you evaluate the option to go a bit deeper with the TELNET interface? A lot of JetAdmin devices have more options via telnet/SSH

1 Like

Hi @greavette

Make sure the mail server definition is configured in Cockpit manager.
Make sure the user is a defined user.
Make sure the IP address of the printer is on the same IP network as the mail server and the masks are the same.
If there is a gateway parameter for the printer, make sure it is the IP of the mail server.

=> Bad sender address syntax
For the IP address, try


ncat -v -u smtp. 587
Ncat: Version 7.50 ( )  (STANDARD OUTPUT LINE OF ncat)
Ncat: Connected to (=> OUTPUT OF ncat IF CONNECTION IS OK)
   (if there is a problem, the above line will be replaced with the corresponding problem)
quit (TO QUIT ncat)
Ncat: Connection refused.

You might have to specify a FQDN address for the mail server in the printer config:

SMTP Server -


Hello @michelandre ,

Really appreciate your reply! I’m unsure how to make sure my server definition is configured in Cockpit manager and that my user is a defined user. Can you provide some details on how I check these?

Thank you.

Hi @greavette

Mail server definition:

Email — NethServer 7 Final.

https;//ip-address:9090 → Applications → Email → Settings → Domains


The domain should appear, otherwise Create a new domain.



DKIM not really necessary but recommended


https;//ip-address:9090 → System → Users & Groups


If module Webmail is installed, to check email: https://ip-address/webmail/

Hoping it will help you.



Wow! I really appreciate your reply @michelandre !

How safe is it to enable ‘Accept unknown recipients’? And would this setting allow me to send email from an internal (to our network) application through our Nethserver mail server?

And if this is enabled but I’ve only opened the required mail ports to allow my mail server to function, will anyone outside our office be able to utilize this ‘Accept unknown recipients’ and send mail through our mail server?

Thank you.

Salut @greavette,

This will accept all mail received but will send the “unknown recipient” mail to the specified user in “Deliver to”. All other mail, to real recipients, will be send to the corresponding user.
That way, people will not know if the recepient does’t exist.

It should if the application is configured correctly. Example: Thunderbird.

By default, the mail ports are opened.
‘Accept unknown recipients’ is only used by the mail server to send “unknown recipeint” mail to the specified user in “Deliver to”.
If you have DNS MX record specified for your mail server at your Register, anyone on the Internet, or a station on you LOCAL LAN, can send an email to anyone on your LAN as long as it is a valid user.


1 Like

Thanks very much for your input on my post. I followed your suggestions and I can no receive emails from UPS management server.

Sadly our Printers are too old to have SMTP work, but I can use Zabbix to monitor our printers and receive the necessary alerts from Zabbix.

Thank you.

Maybe with some fine tuning is still possible. But without any detail share, quite tough having the way to manage it.