SMTP Authentication - how to verify if this is turned on

mailserver

#1

Hi,

I cannot send emails from the Webmail client.
In the logfile /var/log/maillog I find this information:

Dec  3 21:04:30 vm101-nethserver postfix/pickup[19968]: 2188D3A76: uid=48 from=<user@mydomain.de>
Dec  3 21:04:30 vm101-nethserver postfix/cleanup[20414]: 2188D3A76: message-id=<7e7262698b050a98f1816ddfcxxxxxx0@mydomain.de>
Dec  3 21:04:30 vm101-nethserver postfix/qmgr[5659]: 2188D3A76: from=<user@mydomain.de>, size=400, nrcpt=1 (queue active)
Dec  3 21:04:31 vm101-nethserver default/smtp[20420]: 2188D3A76: host mx-ha02.web.de[212.227.17.8] refused to talk to me: 554-web.de (mxweb104) Nemesis ESMTP Service not available 554-No SMTP service 554-IP address is black listed. 554 For explanation visit http://postmaster.web.de/error-messages?ip=91.89.111.222&c=bl
Dec  3 21:04:31 vm101-nethserver default/smtp[20420]: 2188D3A76: to=<cmonty@web.de>, relay=mx-ha03.web.de[212.227.15.17]:25, delay=1.6, delays=0.87/0.35/0.36/0, dsn=4.0.0, status=deferred (host mx-ha03.web.de[212.227.15.17] refused to talk to me: 554-web.de (mxweb002) Nemesis ESMTP Service not available 554-No SMTP service 554-IP address is black listed. 554 For explanation visit http://postmaster.web.de/error-messages?ip=91.89.111.222&c=bl)

The FAQ in SPAMHAUS provides this information:

PBL listings do not prevent you sending email unless your email program is not authenticating properly when it connects to your ISP or to your company's mail server. This can happen if you have forgotten to turn on 'SMTP Authentication' or if you have switched 'SMTP Authentication' off by mistake. 

This drives me to the following question:
How can I verify if SMTP authentication is turned on?
How can I ensure that emails sent from Webmail client have SMTP authentication turned on?

THX


(Roberto Sitzia) #2

Hi @cmonty

if you send email from webmail you don’t mind about SMTP authentication.

Your problem is that your public IP address (given by your ISP) is blacklisted cause maybe it’s a dynamic public IP, you can avoid blacklist using the smarthost feature that enable SMTP relay through an external SMTP server, generally authenticated (or not) SMTP server provided by your ISP.

To enable smarthost feature:

  1. go to Email section
  2. click on Messages tab
  3. click on send using smarthost checkbox
  4. fill in data about SMTP server prodived by your ISP or any other else

#3

OK. This makes sense.

Question:
In case I configure a smarthost, which sender-address will be used?

<name>@mail.<mydomain>.de or <username>@<smarthostdomain>.de

(Roberto Sitzia) #4

A smarthost is an SMTP server that you use only to relay SMTP communications (emails).

For example, if your email server is yourdomain.de and you send an email such name@yourdomain.de using smtp.yourprovider.de as smarthost who will receive your email still see the original sender email address.


#5

OK… got it.

Any recommended smarthost provider?


(Alessio Fattorini) #6

Mandrill :wink:


#7

I guess there’s no free smarthost provider?


(Alessio Fattorini) #8

Yes, check their site. It’s free but you have an amount of email sent per month