ShellinaBox Login

shellinabox

(Martin Droste) #1

NS7
Modul:Shellinabox

hi All,

sry for being away - real live issues…

But now i wana restart and thought to use this great Shellinabox. But at login I tried all users but for no one a password is asked for. What do I wrong at where can I have a look after?

Thx for Help

Martin


(Ralf Jeckel) #2

Hi Martin,

if you have this:

I think your ssh port isn’t 22. Shellinabox only works on port 22 AFAIK.


(Stéphane de Labrusse) #3

use root please


(Stéphane de Labrusse) #4

this is a bug, thank to bring it up


(Stéphane de Labrusse) #5

corrected both for ns6 and ns7


(Ralf Jeckel) #6

Steph you’re great! Update done and shellinabox works with port 2222. Thanks a lot! :clap: :thumbsup: :clap:


(Martin Droste) #7

for me as windows user it’s the best modul in NS7!

ty Stéphane


(Marc) #8

On a side note, the Shell_description language tag appears to be missing.
Why is the terminal menu in the status section?


(Stéphane de Labrusse) #9

yes, you are right, thank

I don’t understand your question


(Marc) #10

Just a minor thing. I mean the Terminal menu entry on the sidebar… I don’t see how a webshell fits under the Status category.


(Stéphane de Labrusse) #11

where do you think the terminal could fit better ?


(Martin Droste) #12

Administration?


(Marc) #13

IMO it makes more sense under Administration, or inside Applications.


(Stéphane de Labrusse) #14

for the administration menu why not, for the application menu I cannot do it because I created a reverse proxy to display the shell directly in the server-manager. It is the greatest feature of ns7, not backported to ns6


(Stéphane de Labrusse) #15

should be good

moved the terminal settings to ‘configuration menu’ (ns6&7)
moved the shell terminal to the ‘administration menu’ (only ns7)

tag added ns6&7


(Martin Droste) #16

:+1::clap: