Sharing a scanner on the office network

Our old office AIO printer just gave up and the scanner feeder does not work any more. We purchased a new scanner (HP Scanjet 5590) and I would like to share it among all users with Nethserver and SANE.
After a quick check, I found that SANE is already installed in Nethserver (backends, utils and saned) therefore I thought sharing the new scanner would have been easy.
I followed the instructions in : but so far I did not manage to get it to work.
I can see the scanner locally (Scanimage -L), I can manually scan from the console but I cannot access sane from the network.
As far as I could see, saned server does not start despite the xinetd configuration (no service listed with : services --status-all) but I can start manually saned and telnet to it locally but not from the network.
Did anyone try to use sane on Nethserver?

Thank you


Did you look for sane on centos? I just noticed a contrib on SME maybe @stephdl could provide some insights

I’m not sure that this contrib is fully workable on sme9, sorry I’m not enough skilled in sane mainly because I have a scanner with an ethernet NIC and it is shared by default with all users of my network.

I’m quite confident that a lot of scanner/printer can be plugged in your network and it’s not worth a module for these specific usages.


Put the scanner on a Raspberry PI and share the Raspeberry ressources on the network…
It’s more suitable and flexible…

1 Like

I think this is the best approach for Linux environment.

I have tried CUPS but you can’t use all the facilities of the new generations of printers/scanners/multifunction.
The main issue are the drivers. I have tried with Canon iR-ADV C2220 and worked only B/W.

Alternatively you can try something like a ‘printer server’ ->

I have never used it, but I believe that it can act like a ‘sane server’, quite sure that you have a lot of other brands and models. Verify the compatibility list before to buy it.

Dear all, I gave up…
I tried to install sane following all the instructions I could find but to no avail. It seems I cannot start the process or I cannot configure properly xinetd.
I tried an external device running openWRT (WR-702N - this was my first choice) but it did not work reliably.
Finally, I re purposed an old laptop with Win10 and left it connected to the scanner… so far so good.
Not an elegant solution, tough

Sorry to hear this :frowning:
I never tried to share a scanner, but I still almost always have problems sharing a printer :smiley: